Missing data from form and failing to export

Collected Data from the form is missing and failing to export

I recently changed the name of a form, added 1 question, and redeployed the form. When I went to export the data, it states “Export Fail”. Also, when I looked at the “Table” in the “Data” section, the data is gone and it only states {“detail”:“Not found.”}. What do I do to recover the data? I’m not sure if it is a bug or something wrong with a setting or question.

Hi @drc_data_dude,

Changing the name of the form, adding a question to a survey project and redeploying them should not affect the project and the data it contains.

Besides, data stored in KoBoToolbox server generally does not get lost unless and until you delete them manually. Also please note that it’s impossible to retrieve the data that you deleted from your server.


Hi Kal_Lam,

Thank you for your response. I agree that the changes I made should not affect the project and the data it contains. However, the problem still remains when I try to export data it states “Export Fail” and when I looked at the “Table” in the “Data” section, the data is gone and states {“detail”:“Not found.”}. What are all the other possible reasons I am facing this problem? Do you recommend any solutions to fix this?

Thank you for your time!

Whad download options are you using? Have you tried all available options?. Note that the table will only have data based on the structure of the latest deployed form


1 Like

Hi Stephanealoo,

I always download using the XLS option. I tried all other available options and all failed to download except for the XLS (Legacy) and CSV (Legacy) options.

As for the table, regardless of any of the options selected (legacys included) it continued to state {“detail”:“Not found.”}.

How can I fix it so that I can download the data option XLS and still be able to see the data in the table?

Kind regards,

I had a similar situation i was working with Enketo web form and i was saving all my data as a draft it was on the 8/12/2020 when i started submitting , all went well from the beginning
have successfully submitted some data and later have power failure with my laptop. Later when i login i could see all remaining data on the form are missing and showing 0. How could i restore my data

Hi @tabwoch,

Do you mean your data did not reach the server after the power failure?

Hi @tabwoch
If this relates to data that was not submitted, then there is a potential problem with how your browser handled the data on the power blackout. Unfortunately, this is not a system issue but rather a potential that your cache was cleared on the outage.


1 Like