Missing data in table & download but is present when previewing

Hi Kal_LAm,
I have an issue with one of our kobotoolbox forms. I can view the entries in their submissions but when I download the data submitted via xls, there are some information that is not included, specifically, the gender name and other information under the same grouping.

Thank you and looking forward to your assistance.

I have attached a screenshot and a sample data extract that I did. I also included in this PM the xls file of the form.ESMF2_Test_Data.xlsx (176.3 KB)
Processing: ESMF 2 Project Worker Sample Form with Answers.docx…
Processing: ESMF 2 Project Worker Sample Form with Answers.pdf…
2.xlsx (23.8 KB)

@gunslinger, could you be specific on what is missing in the downloaded format so that we could funnel down the issue and troubleshoot?

I cant find anywhere in the table the responses for Full Name, Gender, Work Type, Employment Type, etc.

@gunslinger, could you share with me the following through a private message so that we could have a closer look at your case:

  • Username
  • Project name
  • Server

@gunslinger, would you also mind sharing the project name so that we could investigate?

Have you tried search?

1 Like

I cant see it in the spreadsheet. I dont understand the search that you just mentioned.

@gunslinger, when having a closer look at your issue, I observed the following in your XLSForm:

This shows that the information that you are seeking under the DATA>Table and your download which you say is missing is from the repeat group. I could see the repeat group data as shown in the image below when downloading your data as XLS format:

Please note that repeat group data resides in a different sheet as the structure of the repeat group data is a bit complex. Hence they are not displayed in the DATA>Table too.

Thank you. Makes sense now. I tried downloading the default data set and not only my selected fields and I got the additional sheets that you indicated for each repeat group.
Much appreciated.

More power to your team!

1 Like

Hello.
I have the same problem. I can see data in the preview but when I download the file, there are not the other sheets I had last week.


(Today I only have 2 of the 6 sheets I had last week, the missing sheets are in the red square in the image)

I sent you in a private message futher information about my project.
Thank you.

@angelajim, before i make a check at my end could you ensure that you have the repeat group questions for those missing sheets in your latest deployed survey project? I guess that you redeployed your survey project removing those repeat group questions. If you did the same, you could see the sheets missing.

Hi. Thank you for your fast answer.
I just check but in my deployed survey project still are the group question, as you can see in the image.

Thank you.

You should be able to check it more effectively by downloading your data as XLSForm.

Hello.
I dowloaed asXLS form, like this, but some sheets are still missing

Hi @angelajim, the issue seems to be that when the fields are selected in the advanced export options, the repeat groups aren’t being exported correctly. Can you please toggle this setting off and try again? It seemed export all your data in my test:
export
I will take a look into the cause of this, but in the meantime please continue your exports in this manner.

1 Like

Hi @angelajim, I have tracked the root of this down to an old issue that wasn’t correctly fixed (by me :upside_down_face:). I’ve reopened the issue and will deal with it soon:

1 Like

Thank you so much. I hope you could fixe it.

1 Like

Hello again.
It seems the problem its only with the option of download named “xml values and headers”. With this option group questions don’t appear and URL links either. I tried the option “labels” and the donwloaded file has all the missing information with the other download option, as you can see in the next image.

1 Like

Thank you for adding further details to the discussion @angelajim!