Missing Questions when Editing Form


I have a problem editing a form after deployment: all questions have dissaparead !

This happend right after I shared the projet with 3 other collaborateurs. One can see all the questions of the form when submitting a new form, but not when editing the original form.

I need to do changes in my projet and I can"t. I had download the XLS form and there are no options in the “choises tab”. I had around 100 questions, all missing now…

I also tried to 1. save the questions in the library and create a new projet, 2. Clone the projet and create a new one, 3. use another navigator (chrome and microsoft edge), and none of these solutions had worked…

Can someone help me? All my work is just gone ;(

Welcome to the community @danielacorella! Generally if you have say 5 questions (Q1, Q2, Q3, Q4 and Q5) in your form and you make changes (i.e. you remove 2 questions and keep 3 questions i.e. Q1, Q2 and Q3) and then redeploy. You should obviously only see 3 questions (i.e. Q1, Q2 and Q3) moving forward while collecting data.

The best way to check the changes over the deployment is by checking out the HISTORY as outlined in the post discussed previously: