My data for Question matrix doesn't appear in the excel when I download

Hi,
I need help on my data set that i download and data for Question matrix doesn’t appear in the excel sheet. How can I deal with this.
Here is a link to the data; https://kf.kobotoolbox.org/#/forms/aRdRCtgEUrMk3S3khqJ4nZ/data/table

Welcome to the community, @ebarigye! Would you mind sharing a screenshot of the missing data so that we could also understand your issue pictorially?

The_role_of_food_banks_and_Domestic_Agro-processing_-all_versions-False-_2021-11-23-13-09-06.xlsx|attachment (67.5 KB)

Sharing your questionnaire with the community should also be helpful.

https://ee.kobotoolbox.org/x/cs9mbOpG
The link to the questionnaire

Maybe sharing the XLSForm should be more helpful in this case as it would be easy to track down the variable names too.

Here is the XLS
aRdRCtgEUrMk3S3khqJ4nZ (3).xlsx (18.7 KB)

OK great! Could you now let me know the question from where you think the information is missing? I should be able to have a closer look at it to see if I am able to find the data in your dataset that you have shared previously?

The data set that I download doesn’t bring answers for questions that have Question matrix those under section B

OK so you mean data are missing from this section:

Yes the questions that i designed with Question matrix. They don’t appear in the downloaded data set

@ebarigye, would you mind sharing with me the following through a private message:

  • Username
  • Project name
  • Server

Dear Kal_Lam, I found myself stuck in this problem as well. I am wondering if this problem was solved before. If yes, could you also offer me a hand? I have a matrix question in my form. Data collected for this question is visible in table view but not when I download into a .xls file.

Welcome to the community, @moungvandia! Would you mind sharing with me the following through a private message:

  • Username
  • Project name
  • Server

@moungvandia, I went through your survey project and could see that you have 12 different redeployments for your survey project.

Then when looking at the XLSForm more carefully I could see the following skip logic that you had used which should have affected the data collection:

In version 1

In version 12

Hope you are able to track down your issue now. As a check, if you download the latest version of your XLSForm (version 12) upload them as a different project and deploy it and make a dummy collection of the data you should be able to see the data from the Matrix Question (if it should satisfy the skip logic you have applied).

Dear Kal_Lam,

Thank you very much for your prompt response and raise the key issue here. I am will work on it and come back to you if the problem still occurs.

If everything is alright in the new deployed version, could you let me know if it is possible to download the data from this current project and upload to the new deployed project to be able to see those 110 responses in matrix questions? If yes, could you guide me how?

Thank you very much in advance.

Best,
Vandy

Sorry did not understand you correctly here:

Apologize for the confusion.

I have 110 data filled and I am wondering if I could download the data and upload to the new project as you suggested. The question is, will the missing data from this error show in the new project if I am able to upload them?

Please let me know if you need more clarification.

Best,
Vandy

@moungvandia, I would advise you to play around with a dummy project. That should provide you the confidence in what you are intending to do.

Dear Mr. Kal_Lam,

I have tried your suggestion and everything works fine now. Thank you very much for your prompt response and support. I am so impressed with how fast you are in to help me all the way here.

Have a great day. You have saved my life. :slight_smile:

Best,
Vandy

1 Like