My web form doesn t show basemap to record coordinate

I have point, line and polygon question type in my form. I choose web form as a tool to collect data. But when I try to open it on my phone, it does not show the map like when I try to open the web form through web browser in my laptop. Is there any way to fix it?

@faqihr, would you mind changing the screen from portrait to landscape to see how it behaves? Changing your screen from portrait to landscape should solve the issue. Please confirm what happens.

It still does not show, unfortunately.

@faqihr, what do you get after selecting this, as shown in the image below:

If it’s a point, it seems like it will record the coordinate of the phone. (still not showing the map)


But, if it’s either a line or an area, the screen shows nothing but, when I try to delete a node, it will show the node’s coordinate. But still, no map showed up. Unlike using KoboCollect or Web Form on a laptop where we only need to trace the line from the map shown, this web form on the phone seems like we need to walk along the line/area boundary to record its shape.

@faqihr, maybe a final check. Try downloading your XLSForm and check to see the appearance for this geopoint question type. Also try checking this survey link with a different browser to see how it behaves.

I actually haven’t set up anything on ‘appearance’ in Form Editor. What should I write there?

Would appreciate if you could download and check it in the XLSForm. Please also try checking the form through a different browser (other then the one you are currently using).


This is the XLSForm.

As for the different browsers, I tried Opera and Safari. Both does not show anything even when I set my phone in landscape.

Hi,
To make the map visible on mobile devices (from looking at your screens I assume you use Android) you need to add the parameter “maps” (without quotation marks) in the appearance column for any geo widget.

It will then appear as a frame with a button in it’s center labelled with “Map”. Tap this button and the map will show up for manually setting the point.

If you also want to hide the input fields for lat/long etc. the appearance statement to paste is “maps and hide-input” (again without quotation marks).

I don’t know the reason but this is necessary only for mobile devices. On x86 machines the map will show independently from using the maps statement. But the hide input statement also takes effect on x86 machines.

Hope this helps.

1 Like

@faqihr, have you checked out what @DSimon has advised? Feel free to reach us back if the issue is still on.