Not able to deploy XLSForm

Yes, it was validated successfully

@solotheking, could you also let us know the total number of questions your XLSForm has? Please also let us know the server you are using. These details should also give us a clue of what could have gone wrong.

234 questions and i’m using the Educational Services / Higher Education if that’s the name of the server otherwise how do I find the server?
By way of explanation, I’ve successfully replaced this form 6 times, so I’m currently on v7. I only updated a constraint and have since not succeeded in replacing. I also changed the settings style from theme-grid no-text-transform to theme-grid.

Still expecting a response to this challenge, please

Hi @solotheking,

There are 2 public servers for KoBo:

1- The Humanitarian Server:
2- The Non-Humanitarian Server:

You can see which server you are using by looking at the URL of your form.

1 Like
So, it’s the non-humanitarian

1 Like

Any help here please?

I’ve not received any solution to the above issue since it was reported. The issue still persist. What I don’t understand is that when I upload a simple .xlxs form, it pick but when I try replacing or create/upload a new draft, it hangs for hours.
The same thing happened at the newly testing site
What am I doing wrong?
I want to send a link to download the said document for inspection though the online validator runs it successfully without a hitch.

@solotheking, could you share your XLSForm with the community? Maybe the community could also help you identify syntax issues if any present within your XLSForm.

It contains vital staff information that I only wish to share with you and not the community. Can I do that?

@solotheking, maybe you could remove that vital information and keep the dummy information so the community could still help you.

Ok. People, this is my form for which I’ve tried for over a month now to upload without success. The tool is intact except names in the choice sheet replaced. Kindly assist me. Online validator has no issue but uploading and replacing a draft takes ‘forever’ if not impossible.
Monthly Report School.xlsx (1.1 MB)

@solotheking, when I quickly checked your XLSForm the first thing I noticed was the total number of choices. I observed that you had 682 teacher under the choices tab. When you have such a huge list, I would advise you to user the external choices to cascade as outlined in our previous post:

When you have that long cascading selects, the form time-outs.

The other thing I also noticed is that you have used multiple colors within your XLSForm. Try removing them as it’s taking up a lot of unnecessary space.

I’ll try the changes and see the results, but I’ve been able to upload and deploy this same form without a problem and so why is this happening now when I’m only trying to replace it?
I tried the select_one_from_file sometime ago without success. Maybe I’ll have to trim down the number of teachers or if I could be helped with the select_one_from_file version.

1 Like

It seems there is a server upload error or redundancy. I cleared the teachers list from the choices sheet leaving just 3 teachers and still the file cannot be uploaded while the online validator validates it without error.
What could I be doing wrong? And what’s the way forward.

@solotheking, could you once share the final version of your XLSForm so that the community should also be able to check it out for you?

1 Like

So people, I’ve removed all colors and all teacher leaving just 4 yet still I can’t upload this form.
Monthly Report Coded.xlsx (1.1 MB)

Afte 2 clear days of posting this and no help on this issue?

People, I think my problem is solved. I tried uploading the file as usual and quickly opened a new browser page to log in to my kobocollect account and lo and behold the old web page had displayed the settings for a successful upload. Thank you all for your support.

1 Like

@solotheking, :clap: :heart: :partying_face: