Not allowed to post data - error message

I have two humanitarian sites, one for my own testing and one for administration.

I removed all prior instances of a form that I am developing from both sites.

I create a new project on my site from an xls file of the form, deploy it, fill out a form using the chrome browser, and it works fine.

I create a new project on the admin site from the same xls file, deploy it, fill out a form, submit it, and it does not upload.

I see the message “Not allowed to post data to this data survey. Contact the survey administrator please (403).”

I am the site administrator and I logged in with the correct password, so I am puzzled. What am I missing? I am listed as the owner of this form.

Addendum. I have added other previously-functioning forms and get the same error message. Is there a problem with the authentication server? This site has worked flawlessly for months, and I can’t figure this out.

Hi @jblackman,

Would you mind explaining us a bit more on your admin site. Would also appreciate if you could upload a screen of the error message you are seeing with the background of your screen from the admin site. This would give us a hint on the issue you are having.

Have a great day!

I was able to sign in to the humanitarian server with Firefox and I was able to fill out and submit the form without issues.

When I signed in with my usual chrome browser, I saw the error listed above under each form queued for submission.

I cleared the chrome cache, and everything seems to function correctly. (Amazing how much easier it is to think clearly at the beginning of the day.) Thanks.