Occasionally, wrong value being recorded/saved + logic does not work

Hello community. We urgently need some help with a data collection problem. We are experiencing an issue with Kobo which are potentially leading to “false” screen negatives, only occasionally. The built-in logics and automatic messages are working most of the time, and only some of the time we are experiencing this problem.

The problem was that, the inclusion criteria message not shown even though it was met. The inclusion criteria is that the participant should meet the cut off score in PHQ (depression) and FI (functioning) and not be at high risk of suicide. When the inclusion criteria are met, the automated message pops up instructing the researcher to include the participant. However in one instance, the automated message was not shown despite the case being eligible. When the same values were input in the same parameter in the tab of the researcher, the message didn’t appear. However when the same values were input in another researcher’s tab, the message appeared in her tab. The same value was input in the new form after deleting and downloading the form again, the problem seems to be fixed. This problem was observed on May 20, 2024.

Hi @ceren. If I understand you correctly, you solved the problem by deleting the existing form and downloading a fresh one from the server.

I am trying to assist in a non-technical capacity but from what you’ve described it appears that the form might have been updated on the server to fix the technical glitch but the specific user had not updated their forms to the latest version. So in this case, deleting the form and re-installing a fresh one automatically brought in the updated form onto the device.

My quick question would be how many times was the form updated on the server before the teams were deployed into the field. And also additionally, did the specific user download the form before or after any updates made. I am assuming this might have been the case.


1 Like

Hello @surveyorjr thanks for the reply. No changes were made in the server after the initial form was launched, so no updates before the teams were deployed into the field. The user has been using the form since May 8th, with many successful interviews. Before deleting and downloading, multiple users/supervisor tried on the same device and the same error occurred.

In addition, I am informed when it was uploaded initially on May 8th, the form took 3-4 days to be uploaded for some reason.

@ceren, I would also strongly advise you to validate your XLSForm through this online validator to see if the form is working as expected.