ODK Briefcase export error

Hi all, I’m using ODK Briefcase v 1.15.0 and jre 1.8.0_361 with JCE Unlimited Strength Jurisdiction Policy Files to pull and decrypt data from https://kc.kobotoolbox.org. I’m using Windows 10 64 bit. I’ve generated public and private keys using OpenSSL, etc.
I’ve followed the support article carefully, but I’m getting an error in the briefcase log:
“Cannot find any provider supporting RSA/NONE/OAEPWithSHA256AndMGF1Padding”.
I’m not very familiar with java but have seen this error on a number of java/oracle fora, but I can’t make much sense of the solutions. I’ve got to the stage of total frustration. Any suggestions would be much appreciated.
Please also note that I’ve tried ODK briefcase versions upto 1.18 and also downgraded to JRE 7 to no avail.
Thanks, Paul

Welcome to the community, @paulo61! Did you encrypt the project before launching the survey, or was it someone else who encrypted it for you?

Hi Kal,

I encrypted the project, so I generated the encryption keys using OpenSSL and added the submission_url and public_key (with no spaces or carriage returns) as directed by the support article then uploaded the xlsForm to kobo toolbox.

I can use briefcase to pull and export for projects that are not encrypted. I can pull the encrypted project but can’t export the data.

I’ve checked and double checked the format of public and private keys. This morning I tried java JDK 17 since these come with the JCE unlimited policies as the default but still the same error.

This is just a test project so I’ve not lost any access to critical data, but I’ll need to encrypt/decrypt in my next assignment.

Many thanks,