Preview/Deploy Not working

Why when after adding a new question to my form I get a preview error, but upon deleting the new question, the preview option starts back working? I’m trying to figure out what causes this as it is preventing me from finishing my form.

Welcome @cttrc_gis,
Did you check your form with the Online validator ODK - XLSForm Online v2.x? This is
always recommended during development and before deployment.

1 Like

Thanks for the reply. I’m pretty new to online forms so this form I am building from scratch on the kobotool site. To use this ‘ODK- XLSForm Online V2.x’ do I have to download my current form and reupload it to that site?

1 Like

@cttrc_gis., yes and that would help you identify the issue.

Ok ill give it a try. Ill update the results asap. Thanks

I tried the website but when I clicked on submit, I get the same error message that I received on the kobotoolbox website. I really can’t figure out what exactly causes these errors. From what I saw this website seems to be only a file converter as I didn’t see any tools I can use to assist in rectifying the errors.

Small note: Whatever causes these errors from my assumption, has to do with the wording of the questions itself as well as the choices, as I’ve played around with some of the wording and was able to get a preview of the form whereas before when trying to preview, I would get the error message “parameters must include randomize=true to use as a seed”. Doing this for every single question would be super tedious as my form is 50+ questions long. If someone has more information on this it would be greatly appreciated.

As the error message says, probably you used seed without randomize.
Maybe the following can help you:

1 Like

@cttrc_gis, as a backup of what @wroos has advised, you should also be able to solve your issue by following the post discussed previously:

1 Like