Problem installation in my own server

Waiting for environment to be ready. It can take a few minutes.

KoBoToolbox has not started yet. This is can be normal with low CPU/RAM computers.

My server has good features: 20 RAM, 100 GB on disk and 20 vCPU.

1 Like

@Kal_Lam he esperado mas de 600 seconds por 10 intentos.

Having the same problem, did you manage to solve it?

Ensure that you have the subdomains kf kc ee in your DNS

1 Like

I’m following these instructions to check service health and subdomains DNS:

The response I get is : curl: (7) Failed to connect to kf.kobo.[my domain].internal port 80: Connection refused

The server is clean with no other services running. Tried to fresh install many times without success. I didn’t find any solutions in GITHub issues or here, what am I missing?

Thanks for the help

I did everything perfectly and I have the same problem, Today I read about the DNS thing from @jnm’s article with $ dig +noall +answer thing, can you guys @stephenoduor @jnm describe that longer?
How to do the kf kc ee thing.
Which domain should I use? :face_with_monocle:

Hi @Abdulrahman
Welcome to the community forum. On the issue that you have raised, I would like to start by pointing out the disclaimer we provide in our article


Could you explain your problem in detail

Could you also provide information about your server e.g. storage space and speed etc?

Unfortunately without getting a clarity of the exact problem you have on your end, it would be impossible to get meaningful support on the forum.


1 Like

Thanks a lot @stephenoduor! Setting the subdomains solved the problem, the installation finished successfully.

For those struggling with this installing loop problem, set the DNS domain and subdomains all pointing to the server’s ip address:


Then run:

python3 --setup

Public domain name [mydomain]: mydomain
KPI sub domain [kf]: kf
KoBoCat sub domain [kc]: kc
Enketo Express sub domain name [ee]: ee

Doing that solved the problem for me.
Best regards.


Welcome @marcioeloi :+1: Great to hear that it worked .

1 Like

The problem is fixed!
Setting the subdomains solved the problem too.
jnm did mention that step in his article, but my access was limited and I am new to ubuntu servers work.
Anyway thanks a lot.

1 Like

I am getting trained by a software engineer, I didn’t understand the DNS problem because of my limited access to the server’s panel (AWS Panel).
I fixed the problem with him.
Thanks for your advice.

1 Like

@stephenoduor @marcioeloi
Thanks for the input and suggestions, in my case I have also solved the problem I had.


I am unable to view KC page, It redirects to kpi login page.
Any one having this problem ??

Confirm if the problem still persists even when you try re-try the process?