Problem with GPS shape and line modification in Enketo

Hi Everyone!

I’m having a little problem with the gps shape and line recording.
While I’m in the app, everything works fine but when I try to modify my answers on the web with Enketo, I have different kind of errors :

  • Sometimes much more point that I have really recorded
  • Sometimes I have to delete the first point in order to close the polygon.

Can you help me please?

Hi @fpageot

This is not right since it is the data you collect that should appear. Could you please verify by providing what you have when you are collecting and when you are editing.

Could you provide more explanation around which scenarios require this? As it is you indicated that “sometimes”. Does it mean that other times it works? Could identify any difference between the times it works and the times it does not work.


1 Like

Hi @stephanealoo
Thank you for your answer.

Here is an example where we have collected 25 points and 27 appears on enketo.

Unfornutately, we have not been able to identify the differences when it happens or not.

Thank you!

Sorry, could not still understand your issue. Could you kindly simplify it again so that we are able to help you out.

Hello @Kal_Lam,

The process is :

  • we collect gps data on the field (trace or shape) with odk collect
  • we transfer this data to Kobotoolbox
  • we check the data that has been loaded on kobotoolbox with Enketo

The problem is (for this example) :

  • we have collected 25 points (24 + the last point that is the first so that the polygon is closed)
  • In enketo we have 27 points instead of 25 and we don’t understand why.
  • because of this issue we cannot close the polygon unless we manually delete the points


As a quick workaround could you kindly download your data and check them out to see if the variations are see in the downloads too?

1 Like

In the downloads, we have 25 points

So the points while collecting data and the points while downloading matches (i.e. 25 points). So the issue is when viewing it through Enketo (where you see 27 points)?

Yes, exactly !

1 Like

Could you try this for another entry (case) and see if the same happens again?

We have recorded more than 500 gps tracks and everytime (we have tried for more than 10 tracks) we open them in Enketo, we have this problem.

1 Like

So you mean, whenever there is more than 10 points the issue is on?

No I meant that we have tried to open more than 10 of these 500 tracks and for all of them we had this problem

OK, will try to replicate your issue at my end.

1 Like

Thank you a lot @Kal_Lam

1 Like

Have you uploaded and viewed your data (geoshape) to any map application? Maybe someone export with mapping from the community would be able to help you out with your query.

I have tried to upload and view the data on QGIS and on Google Earth and everything works fine.

Enketo was a great way for people to easily modify the geoshape and other data before downloading them.

1 Like

Thank you for confirming that it worked smoothly without any issue.

You’re welcome !
I don’t know if my answer was clear, but that would be amazing if we can still find a solution with Enketo.

1 Like

Curious to hear if you can reproduce it with e.g. just 3 points @Kal_Lam.

@fpageot, could you please post a single geoshape or geopoint value that has this problem (as text, not a screenshot)? Thanks in advance!