Project Editing page loads non stop

Good day Team. Im having issues with loading my project especially for editing, it loads for hours without showing me the formbuilder. Please help, im working on a project that needs to be launched in three days and cannot make required edit.

It has been stuck at this for hours. Thank you

Does this happen even when you log out and then log in again?

Thank you for your response @Kal_Lam . The system keeps logging me out up until I have to login again which is then followed by the endless loading

Would you mind doing the following to see if one of the following solves your issue:

  • Use modern browsers like Chrome, Edge, Firefox, etc.
  • Update your browser to its latest version.
  • Check out in another device to see if the same happens there too.

@Kal_Lam i have tried all fixes you suggested. On Microsoft edge i get this error. could the number of projects i have cause this?

Have you tried it out on a different browser other then Edge? Have you tried Chrome?

Yes, i have tried it out on all browsers. Every time i try to edit a form it shows an untitiled logging in page that loads for a while(15 minutes or more)

@sibusiso, could you provide the following through a private message:

  • Username
  • Project name
  • Server

Hi @sibusiso
Does this affect only this project or it affects all your projects? Could you also run the console (Ctrl+Shift+J) and send a screenshot of the error you see when you are trying to edit the form.


1 Like


Hi @sibusiso, this seems to be due to the size of your form (over 2000 questions). Unfortunately the only work-around will be to download the form as XLS, make the changes there, reupload and then redeploy :+1:

1 Like