Pull data from CSV - Local Language not supported

Hi Community,
This space has helped me lot solving issues regarding data collection.I hope to lean new things from the community.

My issue:
Survey is being held in rural areas where surveyor doesnt aware of English language.
So when i use local language in my CSV for Pull data functionality, kobo collect app
shows ??? like characters.
MS excel supports my local language but CSV doesnt…

Any solutions to this??

Guys just an update…
i pasted the non english column in Google sheets and then downloaded it as csv
it worked out…

Just a thought.
Can i directly linked my Google sheet for Pull data.
I just have to update my google sheet & wont have to upload it as csv repeatdly

1 Like

@vicks88 you got it correct. CSV does not support Unicode. Thus, the local language provided in your csv file should show something like ????.

Hi @vicks88
“Advance user required”

According to stack flow, this should be possible.

Stephane

1 Like

Ohh Haha…Absolutely…Let me deal with excel only :innocent:

2 Likes

thank you @Kal_Lam for your support.
is it possible to add another language to this feature? I tried using 2 languages Label::English and Label::Ukranian, but the feature didn’t work

Welcome back to the community, @Naeim! Maybe this post discussed previously should provide more insights:

Based on some testing select_{one | multiple}_from_file questions support multiple languages only in Enketo but not in KoBoCollect app at the moment.

For more information, see

1 Like

Hi guys!
In case it’s not too late, here are my 2 cents.

Excel is really terrible at handling CSVs. I am working with mixed Latin and Arabic characters and here is what I do, I hope it can help you:

  • After clicking on “Save As” in Excel, don’t choose “CSV” as the file type, but “Unicode text”…
  • After the TXT file was saved, open it with a text editor (like Notepad++, or if you have nothing else, Windows Notepad)…
  • Fields are separated by something else than commas (probably tabulations). If it is the case, make sure you don’t have commas inside text field values (and if there are, put double quotes to those values, for example with a “Search and Replace” based on a regular expression),
  • Do a quick “search and replace” to put commas everywhere as field separators, instead of the tabulation

Or you can use LibreOffice Calc, which will natively produce the right and intended result without additional steps (if you can live with LibreOffice’s bugs and slowness).

1 Like