Reports problem - XML values instead of labels

help please with such an issue. I have “Table display options - Labels”. but when I switch to Reports I see XML values instead of labels. didn’t have such a problem before. how can I fix it?

Welcome to the community, @vladyslavaaaa! Could you kindly share with us a screenshot of your issue so that we could understand your issue pictorally?

the thing is I want to see labels in my reports, not XML values. before now I had labels and it was ok. also I have another project and the report there is with labels.
so I can’t understand what is wrong with it and how can I fix it

@Kal_Lam could you please help with it?

@Kal_Lam If there are any additional details or information you need from me to better understand the problem, please let me know, and I’ll be happy to provide it.
I understand that you may be experiencing a high volume of inquiries, but I would greatly appreciate any assistance you can provide in resolving this issue.
I’m still experiencing this problem and this is impacting my ability to effectively review and analyze the data. :frowning_face:

Hi @vladyslavaaaa,

Are all of your labels in cyrillic alphabet?

Hi @hakan_cetinkaya,


@vladyslavaaaa are this project’s labels also in cyrillic?

@hakan_cetinkaya yes, in both projects the labels are in cyrillic

Hmm, so the problem doesn’t seem about cryllic alphapet. Let’s try another approach.

Are all the questions select_multiple both in the form which shows labels and xml_values?

the thing is that everything in my projects is in Cyrillic. questions, labels, except xml_values of course.
the Reports section shows questions in Cyrillic, answers to “text” questions are shown also in Cyrillic. and ONLY the “value” in “Value Frequency Percentage” section shows xml_values

1 Like

@vladyslavaaaa, I made some tests on my end.

It seems like, if the question is a select_multiple type question, it shows XML_values and not the labels.

EDIT: if the form has at least 2 languages and/or has label::(language)

I also couldn’t find a way to change the report view to XML_values or labels

Best workaround for now seems like to download the data and create your report in a different program.

Please, allow me to share
The solution may be in the following link:

1 Like

@mohammedTaleb7 That’s an interesting behaviour, @vladyslavaaaa can you tell if its working for you?

1 Like

@hakan_cetinkaya, @mohammedTaleb7

it’s incredibly strange, BUT! I made changes as @mohammedTaleb7 recommended. And now I have some answers shown in “labels” some in “XML values”

but still it’s better than nothing)) maybe I need to make some more changes and try again

@vladyslavaaaa, Did you make edits to form after you deployed and re-deploy again? Especially changes in the xml_values and headers of this question.

I think I made too many changes :grinning:

I mentioned the thing that I changed the “XML values” a couple of times before @mohammedTaleb7 appeared, but the report is shown with the values I had before. It looks like @mohammedTaleb7 recommendation worked only for the values that I didn’t change :face_with_spiral_eyes:

Do you know if I can create a new project with this form and transfer the data there somehow?

SO! I have found the form without the changes I made today, then followed @mohammedTaleb7 recommendation and the problem is solved!

thank you @mohammedTaleb7 and @hakan_cetinkaya for your time and efforts!
hugely appreciate your help!