Rest service fail

Dear Kobo lovers,
I face an issue about send a data to 3rd parties through Rest-Service today. does Kobo terminate/suspend this service?

Welcome to the community, @ngimbunny! Could you explain your issue by illustrating the steps you use? Maybe the community should be able to help you out if it’s an issue at your end.

Hello! I’m having exactly the same issue as @ngimbunny described. I have some forms with the REST Service enabled that do not trigger since today.

In my case the REST service is calling a Power Automate API and starts the flow.

I already checked that the Power Automate API url is working. It seems like the trigger does not even start by checking the history in REST Services settings tab:

Other things I tried but did not work is to re-enable the REST Service, and create a completely new service.

Thank you in advance for looking into this.

Hi, same issue here, REST Services stopped sending the webhook to the configured endpoint, it doesn’t even register the any success, pending or failed submissions. We have tried with already productive forms, were the services were running ok until a few days ago, and also on a testing form with a brand new REST service setup, it just don’t send the request.
Sample Form:
Sample POST Bin to monitor post requests:
Submissions on Kobo: 2
REST Services processed:

Hi there same issue here, REST service is not sending to the configured endpoint

@ngimbunny, @smanesis, @pim_bamatic, are you all on the EU server like @rdevita? Kindly please confirm so that it would be easy for us to troubleshoot.

Yes, I am on eu server.

me too I’m on EU server, rest does not work by now

same issue on eu server rest does not work

Hello - yep having the same problem here. We have a series of email notifications set up when new submissions are made to our Kobo forms, following this UNHCR piece (below), and since the move to the Kobo eu server, the REST services don’t seem to be working. Have tried registering them as new REST services and setting them up again, but can’t get it to work like before. Any help would be much appreicated - thank you!

Hello, I’m currently facing an issue where the REST services have stopped sending data to the designated webhook endpoint. The last data transmission took place on Friday, September 1st, 2023. Any assistance or guidance would be greatly appreciated.

@ngimbunny, @smanesis, @rdevita, @pim_bamatic, @julesyuliyusi, @tristihane, @jhteam, please be informed that our team is investigating this issue. We will get back to you soon.

@ngimbunny, @smanesis, @rdevita, @pim_bamatic, @julesyuliyusi, @tristihane, @jhteam, the issue should be resolved now. Thank you for bringing this to the community!

it works for me!thx team for ur support…

1 Like

@julesyuliyusi, :clap: :heart: :partying_face:

Thank you very much @Kal_Lam and the team ! :slight_smile:


@tristihane, :clap: :heart: :partying_face:

Thank you @Kal_Lam, everything is working well on my end.

1 Like

@jhteam, :clap: :heart: :partying_face: