Row permissions issues

Similar to some others who have posted, I am having issues with the row-level permissions. These issues include: although specific enumerators are only supposed to see their own surveys, they can see all surveys (including those administered by other enumerators) when they are saved as draft.
Once surveys are submitted, they cannot be seen by anyone other than the project manager(s), even though permissions have been granted to view, edit, delete, and validate these surveys for the country-level supervisors. In fact, the enumerator and country-level supervisor cannot access the DATA or SETTINGS tabs (they are greyed out). At the top of the Projects page it lists “0 submissions” even though submissions have been made. In the right hand column on the Projects page, it also indicates “0 submissions”.
The “Require authentication to see forms and submit data” box is checked on the Project Manager account. When it was checked on the enumerator and country-level accounts, it did not seem to make a difference, even when new surveys were completed after that change had been made.
I have read both the Permissions and specific Row-level permissions articles and do not understand what is creating this issue.
Thanks for any help you can provide.

Welcome to the community, @adeckert! Would you mind going through this support article and try making a dummy project, sharing the dummy projects with your supervisors and enumerators, and making a test to see if it works as expected?

Feel free to reach us back if it does not work as expected. Also please share relevant screenshots so that the community should be able to view your issue pictorially and advise you accordingly.

I will attach some photos, however I should have mentioned some additional history. I conducted this survey in 5 different countries last year using the permissions that were available at that time, for project managers, supervisors and enumerators, without any issues at all. Although I have carefully clicked the “Require authentication to see forms and submit data” box in all of the accounts and double-checked the permissions given to each account, the row permissions are still not working properly as described in my previous post.

@adeckert, would you mind removing the permissions and reassigning them again to see if that works? Please let us know on what happens.

Hi there,
I removed all permissions for the survey for 2 supervisors and 2 interviewers. I then confirmed that the “Require authentication to see forms and submit data” box was checked in all 4 accounts. Then I re-assigned the permissions to allow the 2 supervisors to view form, view submissions for both supervisors and interviewers, add submissions, edit submissions for both supervisors and interviewers, validate submissions for both supervisors and interviewers, and delete submissions for both supervisors and interviewers. The 2 interviewers were assigned permissions to view form , add submissions, and view submissions from themselves only.
I then completed a test survey as interviewer #1 and saved it as draft. When I logged in as interviewer #2, I could see the draft from interviewer #1 which I don’t believe should be the case. Although the supervisors could see the draft, when a supervisor submitted the draft, the supervisor could not see the submission. It disappeared from the drafts but did not show up on the projects page. There were no submissions listed for the survey and both the DATA and SETTINGS tabs were greyed out. As the project manager, I could see the submitted survey in my account.
We are approaching the end of the pre-test period for this survey and hope to begin the survey shortly. As I mentioned previously, a clone of this survey was completed last year with multiple countries, supervisors and interviewers and no issues at all!
I’m wondering if these issues are related to the recent update?
Any thoughts/help you can provide would be greatly appreciated.

@adeckert, could you provide me the following through a private message? Maybe I could have a closer look at your case.

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

@adeckert, a follow-up. Has your issue been addressed? We had a fix that should address your issue:

Hi there,
When I saw the fix on the chat, I was hopeful that it would fix our problems. Unfortunately it has not. Some users still cannot see the data tab after they have submitted surveys, cannot always see the draft surveys that they have saved, and although I have given them permissions for editing and deleting submissions, they do not have access to those functions.
Is this a problem with the usernames that I have used? Although it would be time-consuming, if I need to change them I will do so. At this point, these problems are greatly impeding our ability to conduct the survey in the time frames required by the project.
Any additional thoughts that you have would be greatly appreciated!

Hi @adeckert, we apologize for the inconvenience this issue has caused for your data collection project. Have you attempted to give those users permissions again after the update and it’s still not working? Note that the update will not have fixed the permissions issues that were caused by it, i.e. reapplying lost / incorrectly applied permissions.

1 Like

@adeckert, as advised by @Josh, you will need to remove the permissions from the project and then again assign permissions. Please let us know how it behaves then.

I will remove the permissions and then assign them again, however please note that I also did this at the end of May.
Also please see the email from one of our supervisors below. There have also been other supervisors who cannot see their draft surveys even if they have been saved as draft. Is this likely related to the permissions issue?
"Yesterday morning I tried again and I fulfilled only one survey (file name: BIH-02-F-013_BY_Form01). I clicked the button Save Draft. Everything was OK. I get a message (window) Finalize record later with message Record stored as draft.

In the upper left corner instead zero was number 1. I opened the hidden left menu – the file was there. Then, I closed Form 1, logged out from KoBo and I logged in again – opened Form 1 survey – opened left menu … record wasn’t there anymore.

I don’t know … maybe I did something wrong but in the testing period when I/we was/were approaching KoBo, through links you sent as, with above mentioned procedure, I/we didn’t have any problem."

@adeckert, we could further investigate if removing the permissions and re-assigning does not work. Thank you for providing all details, which should be very helpful for the community and those troubleshooting your issue.

I removed all permissions for 2 supervisors and 1 interviewer and asked them to test the system. Below is their response:

"According to your suggestion, we submitted two test surveys today, one Farmer P1 and one Dairy Farmer using our account alb_s1.
As you can see in the screenshot below, the DATA options is still not accessible. We can see in the Projects Panel that our two test surveys are added into Submissions but this again, is not helpful to us.

We hoped we could find a solution as it is very important to us monitoring the conducted surveys and by which interviewer."

Please let me know if you have any other suggestions? This is becoming a very serious issue for the survey since animals will be going out to pasture for the summer very soon and the window to conduct the survey will close.

Thank you for making the test @adeckert and getting back to us with the findings! So, could you also share with us the username through a private message whose DATA tab is not seen? We could help you investigate and solve the issue.

Hi Kal, the username is xxxxxxx

1 Like