Saved Enketo webform not loading

Hi there,
One of my team members was entering data on our Enketo webform last week. She was not ready to submit her form she decided to save it. When she went back to the webform today she is finding that her responses are not loading. I went in to look at things with her and could locate her saved form IN her cache. When we clicked on it we got a notification that it was loaded. However the form that gets loaded it is just blank. I then tried to download the saved form to check that what she saved was NOT blank and did contain data. When I opened the xml file created you can see there is indeed data in there, so what she saved is not just a blank form.

One thing that I am wondering might be going on is that we recently redeployed the form 1 week ago. My teammate couldn’t remember the day last week that she was last entering data but it seems possible that the last time she was entering data could have been when we had the previous version deployed and that’s why it’s loading blank.

If it is the case that you can’t load saved form created in a previous version in the new version, is there a way that I can create/give my teammate a link to the old version of the survey and have her just submit that way?

Thanks for your advice!


Welcome to the community, @agriderreiff! I don’t think this is the case.

Would you mind trying to replicate it to see how it behaves? Maybe this should give us a clue of what is happening. BTW, please also let us know the server you are using. This should help us troubleshoot your issue.

Hi thanks so much for your response.

We’re using the Kobo toolbox Humanitarian server. The form we’re using is set to “online-offline” submission. My colleague is using an IBM computer running on windows and using Chrome.

I’ve been trying to add a screenshot so you can see the queue, but am having trouble with that (see below)

I can’t actually replicate the issue on my computer because i don’t have my colleagues form saved in my cache, but we did a screenshare so i could see what she was doing.

When we open the queue I can see a gray box containing the saved form with the name my colleague gave to it when she save it last week. In the upper right corner of the box where the file name is there is an → rather than an “editing pencil”. I can see the upload and Export buttons, however the upload button seems to be inactive/she can’t really click on it. When you click on the gray box itself, the main window on the screen briefly flashes a message to say the form has been loaded, however when we look it is just a blank form w/o any of the entries my colleague tried to save.

Like I shared yesterday, when you download the form itself using the “Export” button in the queue you can see that the saved form is not blank, so this isn’t an issue.

Thanks and please let me know what other information could be helpful.

@agriderreiff, you get the right arrow key → when you are opening the same submission and you get the edit pencil when you are not opening the submission.