Select_one is not working while editing form submissions

Hello everyone,
I’ll appreciate your help in advance.

select_on => “Is a picture required?”
if “yes” shows a group that contains two other fields [Image] and [Text].

Now the problem, it’s working fine for the new form submission but not while editing the existing submissions. selecting “yes” does not show the group.

select_multiple -> show a group that group have -> select_one -> if its yes it show another group.
I hope it’s because of the nesting group.

Welcome to the community @qahmadzai! Do you mean you are able to see the image while filling a new form but are unable to see the image when trying to edit the submission through the KoBoToolbox server?

While editing a submission and I choose “yes” the “Pictures” group is not showing up and in the new form filling it works fine.

Is it a repeat group question?

Yes sir, sure it is.

Would you mind sharing the following through a private message as outlined here so that we could have a closer look at your case:

  • Username
  • Server you are using (OCHA or HHI)
  • Project name

OK do you mean, you were not able to see the repeat group (Add Picture and Explain Picture) when you changed from No to Yes while editing your submissions from the KoBoToolbox server? I tried with a simple dummy survey project and it worked smoothly.

Would you mind trying with this dummy xlsform that i have tried with:

Repeat Group Image Test 2020 10 09.xlsx (11.0 KB)

If i have understood you wrongly, kindly please let me know.

I know it works with dummy xlsform but not working with the one I have sent you.

It’s because of the constraint that you have applied on row G71. Though you pass what is provided on row G69 the row itself is affected by the constraint provided on row G66 which is tied with row 64.

Check the entry made with these constraints. FYI, my dummy worked at your end as there were no constraints but in your case there are constraints that are affecting. For your ease you could also try it out by cloning your project and them removing the constraints. It should work.

As you can see I have selected RCC from select_multi which shows up the “RCC” group in the “RCC” group in the RCC group I have selected 'Yes" but it does not show the “Pictures”, repeat group.

Hi @qahmadzai
Can you check whether the response value for yes is Yes or it is a yes?


1 Like

In the choices sheet “yes” it’s all lower case.
the problem is that it’s working fine while submitting a new form,
But not while editing the existing submission.

Could you provide me the _id for the submission that is having issue. Maybe it would be easy for us to have a closer look at the same.

Dear Kal_Lam,

here is the _id.
instance_id = f7d624e4-5bbf-4985-846d-2827f04142ec

Dear Kal_Lam,

Please I’m waiting for your response.

Could you kindly provide us the _id as shown in the image below:


This should be more easy for us to track your case.

Here are the _id


Do you see this error message while loading your form to edit the submission:

Image 1

Yes in this one “68279674” but in all of them, would you please tell why we get this error too.

Yes, i tested this with 68279674. Do you get an error message with other _id too?