Select_one is not working while editing form submissions

No, I do not get an error with other _id's.

Please sir, We are waiting for your response.

Hello, Kal Lam sir did you find what is wrong with the form.

Hi @Kal_Lam @stephanealoo,

@qahmadzai and I are on the same team and we are still trying to solve this issue. Is there any other way we could go around to solve it? The same error is consistent in all the forms. could it possibly be a bug?

Please help.


Just to be clear, does this error now affect all the forms and not only the form response with the initial ID 68279674?


Hi @joelrhine, @qahmadzai,

Seems like you have put true under the required column for the begin_group as well as begin_repeat which is not needed.

Try removing the true from the same and see if it solves your issue. Kindly please let us know what happens!

1 Like

Hi @Kal_Lam,

We made the changes, but unfortunately it’s still not working.

Hi @qahmadzai,

Did you try this out in a new survey project or on the existing one? Could you also explain us what is not working now?

Hi @Kal_Lam,

I think we have solved the problem by just putting the repeat_group inside begin_group. and move the condition from the repeate_group to the beagin_group.


Thank you @qahmadzai for sharing the solution with the entire community! All the discussions that has happened in the community should help other users with similar issues.