Selecting option for 'Collect Data' not working

The below topic/thread is marked solved though it is not, so posting new topic.

Though it is mentioned to choose the options for desired way to collect data and then to copy the link, the selection doesn’t happen even once to copy the link.

I tried with MS Edge as well as Chrome, still no luck.

We can be assured of the functioning of the link if the drop down too displays the selection we made.

Can anyone help? is there any alternate solution?

@meerakhanna, please have a look at this …


:slight_smile: @Kal_Lam I think you never get that issue from your end. So it will be difficult to explain the issue faced.
It is easily shown in the screenshot, but to enable selection from the drop down box is not happening.
Can you show a screenshot with different option chosen from that drop down, instead of the default?
Then I should ask you which browser you used to make that happen.

@meerakhanna, the steps to get the appropriate URL:

  • Choose the correct options (coded as 1) as outlined in the image below:
  • Once the desired option is selected, press either COPY or OPEN. If you press COPY, you will be able to copy the URL to the desired area/browser you wish. If you press the OPEN button, the browser that is open will open the survey form.
  • So when you have pressed the COPY button, paste the URL to a text editor or word document to see the URL differences that you get from the option you select which is coded as 1 in the image above.

This line, could you replicate in your page and share that screenshot with different option selected?
For the desired option is never getting selected.

If you gonna paste the same screenshot, then I’ll need to drop the hope of getting any solution.

I am adding a video of the issue faced. Request your help.
Browser used is Edge. The same happens with Chrome too.

Unable to add in the video.

Is there any way that I can send you the video?

Can I email you the video of issue faced?

@meerakhanna, well, so this is the first screenshot …

So now this is the second screesnhot …

So from here, if I only wish to take, Online-Only (single submission), then I would select that option …

And I would also COPY the URL, which would be …

Say, if I wish to choose another collection option, then I would go back and then choose and appropriate option again …

So this time, I would choose, Online-Offline (multiple submission), so it would look like …

And I would also COPY the URL, which would be …

So now, if you look at the URLs above, you will see the difference in the URLs. So basically, that UI would only allow you to choose an appropriate URL for data collection.

You should be able to learn more about the same through the support article Collecting Data through Web Forms.

1 Like

@meerakhanna, maybe the following behaviour is confusing you:

If you refresh the page or close and open again, you’ll see that it will automatically go back to Online-Offline (multiple-submission) selection.

This behaviour is nothing to worry about, as you can see in @Kal_Lam’s post, the links are changing according to the collect data method you choose, and as long as the correct link has been shared with the people that you want to collect data, they will submit the form in that setting.

1 Like

@hakan_cetinkaya, :clap: :heart: :partying_face:

1 Like

Now I think i 'll need to check browser setting. For, to me the selection is not happening.

And, I don’t refresh page or do close & open again.

Fine. In case of anyone faced such issue and had fixed, let me wait for their solution.

Anyways, Thank you @Kal_Lam & @hakan_cetinkaya !!!


As I was in hurry, I did uninstall and re-install the browsers.
Now the selection happens,

So unable to find the reason. :frowning:


@meerakhanna, :clap: :heart: :partying_face:

@meerakhanna Me ha sucedido, pero detecte de un tiempo para aca que es cuando uso el portatil y touchpad al tacto, no selecciona ninguna de las opciones como muestra en alguna de sus imagenes, es decir, cuando le doy clic en la parte superior del touchpad y no al boton de la parte inferior del mismo, identifique esto y solucionado el problema, puede tambien probar conectando un mouse, claro esta, si estuviera trabajando desde un Portatil, si esta trabajando desde un PC de escritorio, no tendria otra orientación que dar.


1 Like