Sending Results (Working in my Own Local server) Gives me Error Generic exception: NOTFOUDN


This happens when I try to send an Instance of a form.(A finished one.)

I Have Setup my own local server. Successufuly Edited my /etc/hosts file in an Virtual Android Device Running with GenyMotion. Android 7.0 to acccess the server in my Arch Linux.

What do I have lost here?

(I can get the form but not send one instance, so connection is not a problem here I think)

Are you using the KoBoCollect android app or the Enketo for data collection? If KoBoCollect android app could you share with the community the screenshot from General Settings>Server. This should help us identify your issue.


I don’t know if that makes any sense?
Because I can get the forms from the server, but when trying to send, it gives me that error.

Much appreciate your efforts to help-me.

I assume that the URL you have included here is not complete. Would you mind trying to place the URL that you have shared in a browser and see if it able to direct you to that page?

So my advise would be to use the correct URL.

Here is the URL, I also try to change the server configuration URL to http://kc.kobo.local/super_admin/
but no success at all and the same error arises.

Any idea?

Here is the nginx log with the request:
kf.kobo.local | 192.168.0.90 - - [16/Sep/2020:15:45:06 +0000] “HEAD /submission?deviceID=android_id%3A1d00d11587cd98c1 HTTP/1.1” 404 (0 bytes) “-” “org.koboc.collect.android/v1.27.3-3-gaf2b52f90 Dalvik/2.1.0 (Linux; U; Android 7.0; Custom Tablet Build/NBD92Y)”
kf.kobo.local | 192.168.0.90 - - [16/Sep/2020:15:45:06 +0000] “POST /submission?deviceID=android_id%3A1d00d11587cd98c1 HTTP/1.1” 404 (102 bytes) “-” “org.koboc.collect.android/v1.27.3-3-gaf2b52f90 Dalvik/2.1.0 (Linux; U; Android 7.0; Custom Tablet Build/NBD92Y)”

Would you mind sharing the login link? That would give a clue to identify your URL settings for the Collect android app.

Is that what you means?
http://kf.kobo.local/accounts/login/?next=/#/

See this at my end …

Are you able to login?

With that URL it arises another error:

Yes

But still, can’t send the form.

Are you able to GET BLANK FORMS to your Collect android app with the same URL configuration that you have at the moment?

I Can’t

But with kf.kobo.local URL all goes and I can GET BLANK FORMS well. Except to send the form.

any thoughts?

Hi @Herculano
We have raised this with our developers and they will look at it when they find the time. Unfortunately, since we focus most of our attention on our own installation instances, this may not be as soon as you expect. We would however leave this open to see if other advanced users can be able to provide you with more input. If you don’t mind, kindly provide any additional information that the users can work with:

  1. Have you ever successfully done this before on the same server installation or is this the first time you have tried?
  2. Have you tried reinstalling this (if it is not asking for too much)? There is a huge potential that something was broken during the installation.

Stephane

  1. No, I have tried install this stack on AWS and failed (I opened another post to this issue)
    2, No problem, I reinstalled and the same error arises.

I will give the much information that I have Knowledge, if I can provide any other, don’t hesitate to ask me and I’ll of course try my best.

Fresh installation and the same error arises.
Tried in a new, Google Pixel 3 Virtual Device.
GET BLANK FORM from the server, done.
Send the Completed form, same error again
Since my logs are too damn long I will send them via file, and since here we just cannot send txt files, i will send in csv format but is just log.

Thank you all for you best efforts. I’m really trying to work hard to make it work. Have spended my last 1 week to work on 500 forms. i’m hosting it myself just to move them to PDF, since in the public server all the time some error arises, and I do not have the enketo express 2 API KEY to try via API download the instances PDF’s.

Again thank you all.
logs.csv (47.9 KB)