Skip logic behaving strangely

Hi Folks,

I have used skip logic without issues previously, but in my current form it behaves strangely. My problem is that I often have to “answer” multiple questions before it behaves oddly, but sometimes it behaves strangely when I answer the very first question. I get the errors in the Form Preview Window, as well as if I reply the form.

In the 1st screen grab (Diagnostics 1), everything works correctly. In the 2nd one (Diagnostics 2) I shouldn’t get the white window for “Another bycatch species” because I have selected No in the previous question. If I then try to add information for a new insert, and select Yes for “Are there any other species…”, I don’t get the loop I want that allows me to enter this data - all I can do is opt to enter data fro a new insert (Diagnostics 3), instead of getting the same options as in Diagnostics 1.

I have also attached my xls form, in case this helps. I hope someone can let me know what I have done wrong to get these issues.

Many thanks,

Diagnostics Test.xlsx (10.9 KB)

- You may have a look here for your form structure: Form Logic - ODK Docs
- A relevance for any end (type) line doesn’t make sense.

1 Like

@taniak, when looking at your XLSForm, I see that you have already applied a skip logic to a repeat group at cell G10.

Once it’s applied there, you will not need a separate skip logic from G11 to G13.

@Kal_Lam , you are correct - but removing this redundant skip logics does not solve the problem. I have just removed it from lines 11-13, and I still get the same issue. This time I got the error very quickly in Preview.

I have attached the new xlx form & new screen grabs. I have to say, I cannot work out why this is happenning,
Diagnostics Test.xlsx (11.0 KB)

@taniak, I don’t get the Another bycatch species when I select No … see the image below …

But I do get Another bycatch species when I select Yes … see image below …

Is this what you are expecting?

Hi @Kal_Lam and @taniak I’m also trying to duplicate the issue on my side. ̶I̶t̶ ̶i̶s̶ ̶n̶o̶t̶ ̶c̶o̶n̶s̶i̶s̶t̶e̶n̶t̶, EDIT: It seems consistent now. I think problem occurs when you do the following:

1- Click “Yes” on the “Are there any other insect species in this insert” question.
2- Delete the “Another bycatch species” group of responses by clicking MINUS (-) button.
3- Click “No” on the “Are there any other insect species in this insert” question.
4- Click “Yes” on the “Are there any other insect species in this insert” question again.
5- The PLUS (+) button will not appear to add “Another bycatch species” group of responses.

I think something triggers between steps 3 and 4 which results in not being able to add another group of answers in the second repeat group.

EDIT 2: only tested in Preview mode. Not sure if that changes the behaviour.

1 Like

@Kal_Lam , yes, your images are exactly what I am expecting. For all of my initial tests, this is what I was getting, so I thought it worked. Now, I get the incorrect screens quite regularly.

1 Like

@hakan_cetinkaya @Kal_Lam - thanks for testing. Yes, the problem is that the results are inconsistent. In the examples I sent above, I did not try to make any corrections, as per your suggestions.

Like you, I am testing in Preview. I have in fact deployed a similar form, and it was the enumerators who let me know there was a problem, so I created this test form to see if I could work out what the problem is. I have failed to do so. And in Preview, sometimes I get the correct screen several times before the error shows up. this is what is puzzling - that sometimes it works, and sometimes it doesn’t.

The enumerators that have problems are using Enketo/webforms, and I have managed to get the same issues when I test it on my iPhone (Enketo/webform). I will have to test on an Android (using the KoboCollect app) to see if I still get the issue. Seems odd that the different platforms will behave differently, but then again, maybe not so strange?!

1 Like

@taniak, I don’t have any issues when testing it at my end except what @hakan_cetinkaya has outlined.

@Kal_Lam , may I ask what platform you are testing it on, or if you are also in Preview? It initially took me multiple goes on Enketo to get the result (i.e., I got the correct result a number of times until I finally had the error; now I get it regularly.