Skip pattern involve with multiple choice question

Hi Family,
I want to apply skip patterns in the multiple choice questions such that row9 only appears if option1, 2 or chosen alone or either with another options. I use relevant code selected(${q1_nonfarm}, ‘1’) or selected(${q1_nonfarm}, ‘2’) or selected(${q1_nonfarm}, ‘4’)
and not still working.
I attached the xls form for your assistant
Aurgent.xlsx (11.4 KB)

Thank you all.

1 Like

Hi @Sham_me.
First create a calculated field to separate options 3, 5, 6 and 7. Then just use “and” to join with options 1, 2 and 4 in the q1a field.
Best Regards.
Aurgent_v2.xlsx (12.4 KB)

1 Like

@Sanabria, :clap: :heart: :partying_face:

1 Like

Hi Sanabria and Team I am most grateful for your time.

I tried that and still it does not work.
Example; What I mean is that if you choose theses options;

  1. Sale of seeds and planting materials
  2. Sale of other non-durable inputs such as fertilizer and pesticides and Sale of processed 3. products/value-added products (post-harvest)
    They should be ask for Volume and value sale.
    On the other hand, any option that is selected apart from option 1,2 and 4, Questions on Volume should not popo-up. The problem now if your response in the multiple choice contains at least one of the 2 categories say (1,2,5,7), the volume do not appear witouht any reason.
    See picture below;

The above is what I see in those different kind of multiple choice response.
Still counting your support.
Aurgent_v2.xlsx (12.5 KB)

Thank you.

Try this.
Aurgent_v3.xlsx (12.4 KB)

Hi Sanabria,
Thank you so much for your guide!
How ever, I still not working well.
What I mean is if the multiple response include 3,5,6,7 and 8 is chosen, then we should not ask about the volume. But I still see the question asking about the volume…

There is no option 8 in your xlsForm, but it can be included in line 9 of the “v3” file:

if(selected(${q1_nonfarm},‘3’) or selected(${q1_nonfarm},‘5’) or selected(${q1_nonfarm},‘6’) or selected(${q1_nonfarm},‘7’) or selected(${q1_nonfarm},‘8’),‘1’,‘2’)

I have done that be this is what appears.

When option 3,5,6, and 7 is selected, It still asked of the volume.

Thank you

It’s working over here. Please send the updated file.

But if you select option 1 as part of the option, it brigs the volume questions.

Aurgent_v3.xlsx (12.5 KB)

I really appreciate your time

@Kal_Lam Do you have any idea?

Sorry I have exhausted all the ideas I have.