SSL installation with reverse proxy

@nolive
this is my ssl configuration

Now it redirects in the url but it does not open at all

apache listens on port 80 since when i tried to make it listen on 8080 kobo setup with ssl said it cannot start because 8080 was in use ( I had no option to change it during setup)

@nolive solved by fixing port 80 to 8080 in proxypass and proxypassreverse

1 Like

@nolive but now setup is stuck at 600 seconds altho the pages opens and i can login but i cannot create a form its stuck on loading,

I guess you are running Apache proxy on the same machine as kobo? Your ip could be 127.0.0.1 then.

if setup is still showing dots, it means your setup in now ready yet even if you can login.
You can look at https://kf.yourdomain.tld/service_health/ and report what it says.

Once again, please read the whole thread Kobo-install http/https/certificate nightmare . You may find your solution within this thread.

1 Like

it says everything OK!

My issue now is not SSL anymore cause its working and redirecting as https, now to create a form its looping on loading, i entered my smtp settings which were functioning now whenever i try to register a user 500 error.

I need to do further tests i need to disable HTTPS and see if it works back as normal again.

You must test from the server and ensure the domain name is accessible from the server.

1 Like

all the tests so far are from the server

Oh! kobo-install setup is still printing dots? Even if https://kf.yourdomain.tld/service_health/ reports everything’s ok?

Can you copy your setup configuration? (Hide your credentials)

1 Like

It seems on http forms open well, SMTP still not working altho i can telnet to smtp.gmail.com on port 587 but i need to check with the network team if anything is still closed on the firewall i will post screenshots of my setup now with ssl.

kobo-ssl2