Survey questions too long failing to load

Dear Kal_Lam,

My xlsform is refusing to deploy even when I have 1110 choices only. I tried to create external csv files but the issue is never resolved. Can you please help me? How can I resolve this? Please see attached my xlsform.


midline xlsform.xlsx (272 KB)

@ebizimungu, I could see that you had approximately 5k questions in your survey tab. This number is a large number which affects the performance of the system. Hence you are having issues. To learn more on the same please feel free to have a look at one of our post discussed previously which should explain you in detail regarding why you are having issues loading this xlsform:

@Kal_Lam , Thank you for the suggestions. I have tried to use my android app but still it doesn’t deploy. Last year I had about the same number of questions with more choices than I have now but it worked well. I have no idea why it fails now. I am now stack and I don’t know what to do. If there is anyone who could help, please do.

The best approach to check your xlsform would be by splitting it into different chucks and then uploading it test if there is any issue.

Thank you. Let me try that and see where the issue could be.

1 Like