SyntaxError: Failed to execute ‘querySelectorAll’ on ‘Element’


I am having a similar issue. It says fail to load (happens in multiple devices and browsers, when using web forms), and shows the following error:
SyntaxError: Failed to execute ‘querySelectorAll’ on ‘Element’: ‘:is(.question input[data-type-xml=“geopoint”], .question input[data-type-xml=“geotrace”], .question input[data-type-xml=“geoshape”]):not([data-setvalue], [data-setgeopoint])’ is not a valid selector.

If we try to ignore it and submit, the answers are registered all blank (and it does not allow us to edit).

Please help, because we really need this forms to keep conducting our project.

Welcome to the community, @liana_oliveira! Did you validate your XLSForm through this online validator to see if there are any syntax issues?

The form was working fine until recently, it suddenly started to show this error, without any modifications being made. Therefore, I do not believe there was any syntax issue.
The same problem happened to many of our forms.
I do not know if any modification was made on KoBo servers around that time, but the form is currently working on some devices and showing the error on others. In one specific computer, it worked only after Opera browser was installed, so there must be some restriction related to the internet browser, that we could not figure out yet.

Best regards,


@liana_oliveira, have you tried this with modern browsers like Chrome, Firefox, Edge etc.? FYI, these browsers should also be updated to it’s latest release to avoid compatibility issues.

The browsers we were using when we started getting problems were Chrome and Firefox. I asked about changes on KoBo because they were working perfectly and suddenly started showing problems, so maybe a new change on KoBo demanded that the browser was updated. When the erros first started (on September), we tested all 3 of the browsers you suggested, and all 3 of them presented the error (however they were not on the latest versions). Unfortunately, we cannot update all browsers, because some internal systems would not work.
Thank you for the answer.

@liana_oliveira, could you try loading this survey form on a new device (other then the one that is having issues currently) where you have the updated version of a modern browser like Chrome, Edge, Firefox to see how it behaves there? Please let us know on what happens.

It seems to work in many other devices (that is why we suspected of the browser versions in the first place). What I don’t get only is why is suddenly stopped working on those “old version” browsers.
We need it to work on those specific devices, because we need to copy information from the internal system (that we can only access there). But we are using it on Opera on the moment. Thank you.

@liana_oliveira, this is because Enketo also makes certain updates with the browser update so that the forms collected through the web forms are much smoother utilizing the latest updated features. Maybe you could follow this support article Manually Uploading Submissions to upload the submissions stuck in the browser and update your browser to its latest version so that issue does not show up later.