There has been a problem trying to replace ${.....} with the XPath to the survey element named . There is no survey element with this name

Hi,

cause of I am a new member, so I cannot upload the file here. Please take a look at my file, in the Drive link.

[https://drive.google.com/file/d/18Zmc4Qk-c9EUdQkhcCsCe0-g5d-88m9V/view?usp=sharing]
(https://drive.google.com/file/d/18Zmc4Qk-c9EUdQkhcCsCe0-g5d-88m9V/view?usp=sharing)

I tried and checked a lot, but can’t find where is the error.

Thank you if you check and give me a solution.

Change your relevant expression from

${housing_ownership} = "owned_house"

to

${type_of_ownership} = "owned_house"

In relevant expressions you must put the actual name of the referenced question, not the name of the select question’s choice list.

1 Like

Thank you, I solved it.

However, when I send the link to my friends with Facebook messenger, they face this error:
Failed to execute ‘get’ on ‘IDBObjectStore’: No key or key range specified.

What is that about?

Thanks

I’m unclear what the context is here… what link are you trying to send? [I’m not really sure this is related to KoboToobbox/KoboCollect…]

Dear @Xiphware,

thank you very much for the feedback,

I don’t know why the problem comes, but instead of open a link with the excact address. Sometimes, the messenger poin to the link: https://ee.kobotoolbox.org/x/ therefore the error happened.

Now, it is quite fine.

But, some of the respondent complain about their experience when answer the survey on PC, because the Map auto zoom out everytime they click on a point (in geotrace, or geoshape mode). Do you know how to deal with this?

Secondly, in case they want to use the app Kobo collect to answer, how can they open the link in the app? without signing in,…

Thanks

FYI this is a known issue in Enketo. You can track it here: https://github.com/enketo/enketo-core/issues/259

As for the second issue, I’m not a KoboCollect expert, but perhaps one of the Kobo dev team can chime in (@jnm ?)

1 Like