"There was an error loading Enketo" when trying to edit a record, but not others


I have a form with around 800 records. I have been correcting few of them manually, by clicking on the “pencil” in either the table view or the individual preview. All works well, except for one particular record for which I get the error “There was an error loading Enketo”.

Similar posts (but not exactly the same, I think) suggested trying with Chrome. I have tried Chrome and Firefox and neither seem to work.

It is only one record, but I truly need to edit it. I may actually fill it again from scratch if this is not corrected, but I wanted to report it because I think it is strange that only one record is giving this error.



@amastretta, could you share a screenshot of the error message? Could you also let us know the server you are using?

Non-Humanitarian Server


Hi @Kal_Lam any news regarding this, please? :slight_smile:

Hi @Kal_Lam and @amastretta t would be greatly to know how you solved this issue if you managed to solve it.

Hi I am not sure this is a solution to all similar issues but I resolved the issue but redepoying my xlsForm. The error seems to have come from a media::image file with no label . but i still kept it without the label and it still works

The redeploy solution didn’t work for me. I was able to edit by clicking on tick box and then going to edit on data page as it doesn’t need to open a separate enketo page. But similar issue as well and it doesn’t update in the table view. Changes only visible in the view option.
An update on the issue would be great to understand reasons behind the bug.

Edit: I had redeploying the form without replacing it. Replacing (by reuploading the same form) and redeploying worked well, thanks @sam_k_a!

1 Like

Hi! It worked for me as well :slight_smile: