Thousands Separator Appearance


I was wondering if there’s anyway to set the thousands separator appearance to integer or decimal fields. I’ve been trying to get it to work with the ‘thousands-sep’ appearance command with no success.

Thanks in advance.

Could you explain how you have been trying to get this set up to best understand your context? If you don’t mind, kindly share an example of your working


Hello Stephane,

I’m uploading a sample image of how I’m setting the instruction on the form. I’m asking questions about production incomes for the annual production of farmers in rural and remote areas, so it would be ideal to have the field showing thousand separators so they don’t get confused while entering the information (due to the currency that they use, the nombers can get to be in millions).

Thanks for your previous reply and your help in this regard.



Could you set up the appearance as thousands-sep only and not w2 thousand-seps and see if this works

1 Like

Found this answer in another thread - a pity, as I too would love to have thousands separators as an appearance option in webforms.

at least in Preview (Enketo) you get this (formatting below the field), when you leave the field):
Maybe not working for grid style?
Kind regards


You are right @wroos thousands-sep does work for web forms (preview AND deployed) on the OCHA KoBo server now - since the March release - will post a note in the other thread to this effect.

I use a standalone KoBo server and we are a couple of versions behind - time for us to upgrade to get this fab display option! Cheers

1 Like