Trouble with API connection Kobo to PowerBI

Hi all,

I encounter this problem when I connect KoboToolbox API to PowerBI. The response is shifted to another column like shown in the image below:

in KoboToolbox, the data was fine,
Any feedback is appreciated.
Thank you!

Welcome back to the community, @midoen! Could you check if your data has any line breaks?

There’s no line breaks on the value.
It does have commas, although I formatted the API to csv, I don’t think that’s the problem.
It worked well when I formated the API to json, the problem occurs when I use csv.

@midoen, did you also try using the xlsx type to see how it behaves?

Hi @Kal_Lam, I did try it. It returns to something like this:
The “Open As” is not clickable.

@midoen, does it behave in the same way when you connect your data with Excel Power Query?

Hi @Kal_Lam ,
Thank you for your response.
I’ve tried connecting my data with Excel Power Query, and it’s the same.

OK, as a cross-check, identify the _id and the variable that has this issue. Download your data in Excel format, and then check out to see if there is a line break in that response. There were similar cases reported previously, so I assume it’s the same case.

Hi @Kal_Lam ,

Apologize for just responding to your reply.
Yes. There is a line break, especially on the “Address” (text type question).
Is there any workaround to solve this?