Unable to auto-detect delimiting character; defaulted to ','

Dear sir

Why am I getting “Unable to auto-detect delimiting character; defaulted to ‘,’” error while connecting with parent form from child form.

It used to work with the same xlsx form but now when I was trying to do the same in different account I get that message.

Can you please guide me in the issue.

@ready2readchallenge, did you check out the support article to ensure that you followed all the steps?

Hi @Kal_Lam

the problem is solved.

by the way, i was trying to get api of this new server https://eu.kobotoolbox.org/#/projects/home.

I can’t access it as i used to get api. Can you please guide me.

I used this above link to get api code of my project.

which link do i have to use to get api as this one is not working… I think

thank you

Hello @ready2readchallenge , how did you sort out the issue of unable to auto detect delimiting character; defaulted to…I am having the same problem now. Kindly assist

Hello @paul_maleya ,
Do you still face the issue? If you do, would you mind to share the project uid, project title and your username in a private message?

1 Like

Maybe, the search function of this forum can provide hints and examples, as similar errors have been discussed before here, see Search results for 'Unable to auto-detect delimiting character; defaulted to' - KoboToolbox Community Forum.

Dear Nolive,

I currently don’t have this issue but my partner’s staff has this issue time to time, and we currently have a solution for it, and it work. When you face this issue, you just change the country of your account to US and your problem disappears. I just tested it again today and it worked, i am not sure why this happening

1 Like

This may be related to the Excel language configuration, esp. value separator in csv (, or ;).

but i doesn’t happen in all accounts, one of the two accounts created at the same time has this issue, other one doesn’t. nothing else is different. Few people in the community tasted the same thing, and got the same result

1 Like


Actually, you don’t have to change the country. You just have to press “Save changes” on your account settings, even if you don’t change anything. All new accounts are affected only few older ones.

We are working on a bugfix which should be released soon.

I’ll update this post when it’s fixed

1 Like

Probably fixed now with the new release, see Release Notes - version 2.023.37 - #13 by nolive