Unable to delete or edit some submissions

Hello Kobo Community.

I have some strange error inside the system that some submissions are being duplicated and i don’t know why. When i try to see, edit or delete the submission it pops up an error saying that i can’t delete/edit it (“Failed to delete submission” or “There was an error loading enketo”)

I think it was because of the REST service that i had, i deleted it, but still didn’t let me delete or edit any submission.

Any clues?


Welcome back to the community, @Juan! Could you also share a screenshot of the issue? Would you also mind letting us know the server you are using?

Thank you Kal for your answer.

I attach the screenshots of the duplicated rows, and errors.

Failed to edit
Failed to edit

Failed to delete
Failed to delete

Duplicated rows (i created that unique ID based on some random values and inputs)

I am using the OCHA server (https://kobo.humanitarianresponse.info/). I noticed that happened in some of the forms only.

Thank you!

@Juan, you will also need to check the duplication of the submissions through the _id and _uuid. Did you also have a chance to look at the duplicate submissions through these two variables?

Hello again Lam.

I attach the screenshot.


It seems that the _id is indeed different but the _uuid it is not, i know that the _id identifies an specific row, however the _uuid i don’t know what is or its purpose.

Thank you Lam!

@Juan, would you mind sharing with me the following details through a private message? I would like to have a closer look at your case.

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

Done, thank you.

1 Like

Did you also use the REST servers for this project?


Yes i used them for all the projects inside that user account and it worked just fine, but i think it was responsible for the duplication, so i deleted it. The weird thing is that only duplicated values in some of the projects (only 3) of the 12-13 that i have there.

OK. I will have a closer look and get back to you soon!

@Juan, one final question, did you also upload the submissions manually to your server?

Hello Kal, thank you for the follow up.

Yes, we uploaded them manually using the forms.

Thank you again.


So this means you uploaded your submissions manually as outlined in this support article Manually Uploading Submissions? Or, could you provide details on how you did it if it was something else?

Hello Kal.

I am so sorry, i misunderstood the question, i wanted to say that we upload them just filling up the forms (like this one: Enketo Express for KoBo Toolbox etc) we didn’t use any other method to import data or anything, just filled up the forms.

Thank you.


@Juan, could you also provide more details about the REST services you used for this project? Maybe the details should help us spot the issue and prevent it from happening in the future.

Hello, thank you for the follow up.

I followed the steps under the title: **E-mail Notifications using Microsoft Power Automate (formerly Microsoft Flow) ** from this archive provided by UNHCR:


. It worked perfectly, but i believe it was the cause of the issue.

Thank you Kal.


1 Like

Thank you for providing all the details @Juan! I will reach you back if anything else is needed.

Hello Kal, how have you been?

Any news regarding these issue?

Thank you for all your help.


1 Like

We will get back to you soon @Juan!

Hi @Juan, please note that the issue should be resolved for those projects :slightly_smiling_face:

1 Like