Unable to deploy your form cannot be deployed because it contains errors: Expected value: line 2 column 1 (char 1)

I have my server setup with kobo on workstation mode. Everything works fine in workstation mode. But as soon as it is deployed in server mode with staging on, the SSL is activated and the following error is thrown when I try to deploy the form. Please help here.

unable to deploy
your form cannot be deployed because it contains errors:
Expected value: line 2 column 1 (char 1)

Welcome to the community @sidharth!

Kindly please be informed that you get this error message when you have a syntax error within your xlsform. To identify the issue that is causing the deploy error, we would recommend you to test your xlsform here.


I am not using XLSForm. There was an option to download XLS. After downloading, I tried uploading it in the ODK validator. It says that it is valid. Kindly help

Would you mind trying to upload your xlsform to a public server hosted by KoBoToolbox either to the OCHA server or to the HHI server and see if you are still able to upload successfully?

1 Like

@Kal_Lam We tried uploading the XLSForm for the same form on Public server and were able to upload it successfully.

Please let me know if there is some exclusive support available for Kobo as we are customizing the solution as per our needs.


So it seems that your installation is not working correctly.

Yes. It works fine if I deactivate the SSL. As soon as I activate the SSL, the same error is followed. Is it possible that I could get the details of stable versions of github repo? Or can we get some exclusive support?


I will be changing the topic of the discussion to Own Servers.

Unfortunately, we cannot provide exclusive support to installations on private servers.


1 Like

Hi Stephane,

It would be great if you could give us the stable versions all the github repository so that it could help us in customization and getting up a stable build.


Hello @sidharth,

When you pull kobo-install and use the stable branch, it does pull all latest releases of KPI, KoBoCAT and Enketo Express.
We use the latest version with SSL and staging on for our staging servers without any issues, so I guess the error you receive is somewhere else.

Expected value: line 2 column 1 (char 1) makes thing that KoBoCAT is not responding properly.
The way it works, KPI sends some requests to KoBoCAT and it expects JSON response from KoBoCAT. If it is not, you receive this kind of error.

Have you activated SSL with kobo-install or with your own installation?
What does https://kf.yourdomain.tld/service_health/ say?
What does https://kc.yourdomain.tld/service_health/ say?