Unable to download data using xls format

Hi Kal,
So i am working on monitoring & evaluation about youth who are placed in a firm. i have previous data collected about firm and youth information. if a firm hosts 3 youth then i wanted to evaluate all of them.

  1. Q1: asks firm ID
  2. Q2 generates all youth in that firm (using the csv file) : this question is a multiple selection
  3. group of questions that need to be repeated to evaluate all selected in Q2.

The program worked and i was able to submit data, but when i try to export the data is displays an error and when i see the tables, it was empty starting from the repeat question. so I decided to remove the grouping under the repeat thinking this could be the issue.

then when submit the data i was able to see at the backend & it was there in the table but then when i try to export i see the same error. when i hopeover my cursor on the "export failed " it shows “'youth_id.csv” it shows the csv file

my question is

  1. can grouped questions be repeated if so please help me by sharing an article
  2. i still can not export the data and i dont like many entry being in one line
    please help
    to make it more clear i have share with you both files

a44DczD8tmRxUitj4GwCbx.xlsx (18.6 KB)
youth_id.csv (7.4 KB)


Back again, so when i try to download using XLS(legacy) it allows me to export only if i select the advanced option and when i try to download it few times i was able to download and other time it says i can’t download.

it also bothers me to download using the legacy as it is not recommended

please guide me

hi @Kal_Lam can you please support on the downloading issues please ?


I designed a program that preloads a values as multiple selection based on the answer from previous question (from csv file). but now when i see the data, i see them on the table but unable to download as xls file but only with xls(legacy).
can anyone please suggest


@wb_cjc, did you make any redeployments to this project? Did you try to bulk-edit the submissions from this project?

hi @kal_Lam,

there were alot of redeployment since it was under design phase .it is a pilot data submitted at different versions. but i have noticed the error at the beginning. i have also sent detail information as a private email a week ago. the issue still persist and couldn’t figure it out

let me know if you need further information

@wb_cjc, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

@wb_cjc, I quickly checked to see if it breaks at my end, too, and I got the same Export Failed Error message. It seems like’s something breaking due to the CSV file. I will need to investigate further. I will update you when I find something.

thanks and looking forward!

1 Like

@wb_cjc, your issue is with the question type select_multiple youth_id.csv which you have used instead of select_multiple_from_file youth_id.csv that was breaking the download. You have used this wrong question type in many of your form versions. The latest version has been corrected and deployed. So you should now be able to download your data in XLS format, but you will need to uncheck the Include data from all 46 versions to download your data as shown in the image below:

By doing so, you can only download the data from the latest version. You should, however, still be able to download the full version through the XLS (Legacy) format.


Many many, thanks!!! it worked Perfect!!


1 Like

Wanted to ask the same question, but already found your discussion. Thanks for answering. I think not only me will be useful information!

1 Like