Unable to save new changes (edits) to already used questionnaire

Hi everyone,
A little help. I cannot save new changes (additional questions or response categories) made to the questionnaires I have been using to collect data. I get a response as per screenshot each time I try to save (Error saving form).
So far I have tried the following and NONE OF THEM HAS WORKED;

  1. Currently using latest version of google chrome
  2. Unarchived the project (was editing it in archive)
  3. Connected to a different Wi-Fi
  4. Logged out and logged in
  5. Cleared cache memory (all)

Any pointers? Thanks.

Welcome to the community, @emalambo4! Yes, you could download your form as XLSForm and then upload it back to the server (to preserve the updates you made to the form).

1 Like

but the change are not being saved through form build from Kobotoolbox…downloading the XLSForm gives me the old version, one without the new edits

@emalambo4, deploying the survey form can only save the changes to your form in the formbuilder. But please feel free to reach us if the same issue persists again.