Unable to submit form responses ("Error: Generic Exception: Error: Forbidden")

Hi Kobo Community,

I am seeking some urgent support. We are in the middle of a pilot project requiring significant data collection in the field using Kobo Collect. This was going smoothly until suddenly the officers using this form started receiving the following error message - “Error: Generic Exception: Error: Forbidden” - and were unable to submit any more responses. Please see attached screenshot for information about the error code.

I’ve rechecked the settings several times and tried to redeploy the form, as well as look online for any forums that address this error, but I’ve had no success to resolve the issue. Your support is required and much appreciated as we are losing the opportunity for valuable data to be collected the longer that this issue persists.

Thanks in advance.

WhatsApp Image 2024-06-11 at 10.37.52

Welcome to the community, @aashaup! Is this an issue with only a single user or is it an issue with multiple users?

Hi @Kal_Lam, thanks for your reply. Multiple users are having this issue…

@aashaup, did you make edits to the forms on the server and redeploy your project? Could you let us know if you made any changes to the project?

@Kal_Lam yes, there were some minor changes made (specifically to make the questions mandatory to answer before moving onto the next) and then the form was redeployed.

@aashaup, I have a sense of feeling that you downloaded the XLSForm and then made changes to it. Deleted the project that was deployed on the server previously and made a fresh deployment of the project with the XLSForm which you made changes to. Is this what you did?

@Kal_Lam yes i did this but the users were able to submit responses when I had done this. More recently I just made changes to the form on the Kobo website (to make questions mandatory and minor text changes). What do you think?

Hi @Kal_Lam following this thread up - do you have a solution for what could be happening?

@aashaup, so you meant, you deleted the project and deployed another version (updated) of the project? Did I get you correctly?

Yes, but I did this some weeks ago and there was no issue with submitting data from users after this. More recently, I had made some changes/edits to the form online (via the Kobo webpage) and after this it seems there have been issues with submitting data using this form. No other settings were changed at this point.

@aashaup, sorry to know that you deleted your original form from the server. If this is the case, kindly be informed that the system will not allow you to upload data from your device as the system will not be able to match the form version (that was first deployed, which is in your device but now which has been changed on the server).

So in this case, the only available option is that you can extract your collected data using the ODK Briefcase as outlined in this post discussed previously:

Hi @Kal_Lam, I think there’s some confusion. I’ve tried to illustrate the timeline of events below, I hope this helps.

  1. Kobo form developed online (using Kobo project webpage)
  2. XLS file downloaded and changes made to form - form redeployed and URL shared with users
  3. Users collecting and submitting data using form (via Kobo collect mobile app) without any issues
  4. Minor changes made to Kobo form (via Kobo project webpage - not XLS file) and form redeployed
  5. Issues with data now being submitted using this form

@aashaup, sorry seems like I misunderstood your issue. Could you kindly share with me a screenshot of the Settings>Server from some of your users device that is having submission issues? Maybe that would give me some clue on the configuration side.