Unbold a text to be able to bold specific words

I created a table with matrix. The text in the first column appears in bold. How can I unbold it so I would be able to bold specific words in it and not have it all in bold?

Hi @nz54,

Can you provide a screenshot?

1 Like

@nz54, the simplest way would be is to download the matrix question as XLSForm and then remove the bold as fixing the markdown as needed.

Bold might be the Kobo system default for question labels in such matrix structure, see Question Matrix Response Type — KoboToolbox documentation.
So, how could this be changed?

yes I already have the XLS form, but how do I remove the bold? It appeared as default for the column on the left

I need to unbold the forst column on the left

Can you share the related part/ extract of your form, please?

The ** before and after the section I need to bold are not working because kobo is bolding the whole column on the left as you can see in the first screenshot

Would you mind to share it in XLSForm (Excel), including all the column headers, please?

Why are some colums/cells in bold in the choices sheet? Could you change this?

I removed the bold in the cells but nothing changed when I deployed the form.
I’m sorry I’m not allowed to share the whole form. we have a confidentiality clause.

Maybe you could provide an extract (lines) or at least the screenshots above with complete Excel column headers, please?

1 Like

Sorry, would you mind to share exactly the related part/screenshot of the issue, please, see Unbold a text to be able to bold specific words - #6 by nz54.
Preferably as extract of these lines in Excel xlsx format, so, we could test adaption from.our side.

There seems to be no markdown) to directly remove bold in labels in Enketo (Web form).
A workaround might be to use other options to highlight specific parts, e.g. italic, see Form Styling - ODK Docs. Also read_only can be an option, see below.

It is strange, esp. for matrix formats it seems to depend on your form settings and if the variable/element is read_only. What is possible is shown in the attached example.

Markdown03Unbold.xlsx (13.2 KB)

If you remove settings “grid-theme”, part of the matrix will automatically move to bold. (Could even be a bug? @Kal_Lam)

Here the different visual appearances

*** Default theme

  1. No setting (except no-text-transform), without read_only

  1. No setting (except no-text-transform), but with read_only


  1. Setting theme-grid (and no-text-transform), without read_only

  1. Setting theme-grid (and no-text-transform), with read_only

It’s ok thank you! I’ll manage without bolding this selection.
Thanks for trying to help though!

After more testing, I think, there is an interesting option for you, see example. Make sure that you use settings = grid-theme and maybe read_only for the matrix header part. Would you mind, to try this out?

Furthermore, it would help the community and to check for a tool bug, if you could share the related lines of your form (with the w-formatting), please.

yeah I’ve put theme grid, pages and no-text-transform and I have it all in bold, but it’s probably because I have several columns in the table and you don’t.

Did you also try to set the header/leading item to read_only (column) = true?

I trust you used the spelling theme-grid, with hyphen. (Hint: Pages doesn’t change the bolds.)

It would really be great if you could share/extract few lines or create a similar form part, to allow us to reproduce your issue, please.

I tried, it didn’t change anything.
here goes a screenshot

read_only is a separate column, with true in the cell of the matrix header/leading field. See documentation, please: Form Logic - ODK Docs.

We would need an extract with all columns and all lines related to the first UI screenshot you posted: https://forum-kobotoolbox-org.s3.dualstack.us-east-1.amazonaws.com/optimized/3X/5/5/5526de33b07cef9f77d09bd4875dcb792b5eaeee_2_1380x776.png
Would you mind to extract this as an Excel xlsx file, please?