Unexpected KoBoCAT error 400: b'{"detail":"Expecting parameters to be in the form of \'parameter1=value parameter2=value\'."}'

This error message is not hinting at a row, so I spent a lot of time with trying to find the problem. Finally, I uploaded an unchanged form and – received the SAME ERROR MESSAGE! By the way, just redeploying the form (without uploading it afresh) in the context of uploading a new media file didn’t result in any error message.

So, something seems to have changed on the system’s side. How can I get out of the trap?

@york_rff, did you also validate your XLSForm through the online validator?

Yes, same message without further details (even the old validator version).

Maybe you will need to share your XLSForm with the community! The community should be able to help you out.

It is more than 1000 questions – sure?

No changes on the system’s side? No typical cases/issues triggering this kind of error message?

Here is the xlsform – can anybody provide an idea what to look for in order to find the source of the error message???

We are completely blocked at a critical stage (and going back to the last working form is not possible, because it creates the same error message).

Anybody any idea, at what kind of formulas “\’parameter1=value parameter2=value\’.” might be pointing at???

I — DO — NOT — BELIEVE — IT !!!

How simple can solutions be? I went through the parameters column again (where I thought I had only used it for restricting the image sizes) and found a “30” in a field of the type “geopoint”.

It has been there for ages (at least I found it in a long abandoned version of mid last year) and only now it started to cause trouble. So maybe others experience the same issue. Solution: just delete the wrong entry!


Thank you, @york_rff, for sharing the solution with the entire community! The community should benefit from your solution. :clap: :heart: :partying_face: