Updated Kobo Deployment Instruction

#1

Hi all,

Can you please share a sample configuration using sample organization (sample.org) for the latest Kobotoolbox platform with out using Kobo-Install module.

Thank you
Nuredin

1 Like
#2

Hi Nuredin,

I believe that kobo-install takes your answers to its questions and creates kobo-docker and kobo-deployments directories that store the actual configuration. Why not try running kobo-install with your domain and then inspect those two directories?

John

#3

Thank you John,

I have tried that and after everything is completed it’s throwing an error “Something went wrong”. This also happens to me on the previous version and i was able to setup using kobo-docker option. That’s why i stick with the kobo-docker option to re-install kobotoolbox. Any way i’ll try it again after rebuilding the server.

Just for your information
I am using Ubuntu 16.04 server, komodo wild card ssl and DNS records configured correctly.

Nuredin

#4

Hi John,

I have rebuild the server and use kobo-install. But the same error happen again. It says “Something went wrong! Please look at docker logs” . I have created issue log here on github.

Thank you
Nuredin

#5

Great, thank you for opening an issue. I just responded and tagged a colleague who I believe saw the same ImportError: Missing redis library (pip install redis) recently in his development environment.