View data table filter not working properly

Hello everybody,
I am having a similar problem. The table does not display all filters. My dataset is very small (only 182 submissions). How can I solve this? Thanks!

1 Like

Welcome to the community, @trudi! Could you also let us know the question that you are having issues that has been shared?

Hello, questions 6 and 10 in the screenshot, and several others, do not display the filter.

@trudi, could you share with me the following through a private message so that we could have a closer look at it:

  • Username
  • Project name
  • Server

Cannot send private message

@trudi, you should now be able to send a private message. If you still have issues please refresh your page.

@trudi. sorry could not locate your server. Could you share with us the login URL so that we could be able to identify the server you are using?

Hi @trudi
Just to be sure, can you confirm if your username is as you had shared with @Kal_Lam . On the system, we do see two accounts with that similar names within HHI and OCHA servers. None of these accounts actually have the project you had indicated. Kindly confirm your username in a private message copying Kaylan and then I will look at it


1 Like

@trudi, kindly please be informed that this is a bug. You could follow the same through this GitHub issue:

Will however let you know when it’s solved.


Hi @trudi
I am following up on our discussion (from private chat). I noticed that you are on the UNHCR server and not on HHI nor OCHA. When you are looking at the filter option, I would suggest you give indication on the following:

  1. What are the data/question types that do not have a filter option?
  2. Does this problem affect this project or does it affect all projects? If you don’t have access to many projects, could you try ask other users or probably your admin within the UNCHR server if this is the same to other users?

I will keep my colleagues @Kal_Lam and @Josh in copy just in case you respond when they are around.


1 Like

Hello there!

I’m having the same issue, where data table filters from select_one or select_multiple questions are displaying blank lists. Is there any way to solve this?

Thanks for your help,


Welcome to the community, @charlotte! Are you able to see them when downloading your data as xls format?

Hi @Kal_Lam,

Thanks! Yes I do see the responses both in the data table on and when I download the data as XLS, and the filter works fine in Excel. It’s only in the data table filter that the response options don’t show up. I tried using both Google Chrome and Firefox and cleaned my history and cookies, but the issue persists.

Here’s a screenshot, if that heps.

1 Like

@charlotte, thank you for the screenshot. Kindly please be informed that we already have a GitHub issue for the same. Maybe you could follow the same here:

Will however let you know once the issue is resolved.

Here I am new never understood how to use this method performance

Hi @arok
Welcome to the community forum. Kindly advise if you need advice on using this particular application or whether you have challenges in using it? I would request that you look at the trail of messages provided on this trail in both cases.


1 Like

Hello everybody,

I am also having a similar problem. When I select particular school in drop down, We are getting other school also in the list which I have attached the file. How can I solve this? Thanks!

Welcome to the community, @vineet! We already have an issue for this in our GitHub: