Access Denied / Bad Gateway on local workstation install

Survey is inaccessible on a local-workstation install.

After apt install of and docker-compose, and hack of docker-compose as documented here, I was able to get kobotoolbox running locally.

I deployed a test project, but when I tried to get back into it, I received an “Access denied” message with “Additional details: 502: Bad Gateway”.

What went wrong? How do I troubleshoot/fix it? I am unfamiliar with Docker, which seems a lot like Java: the promise was “Write Once, Run Anywhere” but the reality is “Write Once, Debug Everywhere”. Docker doesn’t seem to be a good general-purpose distribution/deployment tool. Most frustrating.

OS: Linux Mint 20.3 (derived from Ubuntu 20.04)
Docker version 20.10.21, build 20.10.21-0ubuntu1~20.04.1
Docker Compose version v2.17.2
Python 3.8.10
kobo-install Version: 8.0.2 (build e94f178)

May I suggest that the project produce a Virtual Appliance, along the lines of Turnkey Linux or BitNami, with all the Docker and Python version incompatiblities resolved and the containers already set up?

@dwight, maybe try this out as outlined in the post discussed previously:

Thanks for following up.

I tried installing it with on a completely fresh machine any number of times.

I’ve since discovered a likely culprit, after several days of trying (unsuccessfully) to set up a Docker instance that would work with kobo-install. It turns out our campus firewall is not allowing the outside world to access the server. This prevents LetsEncrypt from working, and I’m almost certain that this leads to the observed installation failure. I think it’s safe to mark this issue as resolved.

It would be helpful if kobo-install (or LetsEncrypt/CertBot) had better failure diagnostics, and/or KoboToolbox had a VM appliance.

1 Like

@dwight, :clap: :heart: :partying_face: