Alternative to jr:choice-name (show label instead of name)

Hello!

I realized the reason why I can’t access to drafts and to the edit mode in sent forms is the jr:choice-name call, I need to show the label chosen and not the name…
I don’t know why this function is not supported anymore, or what is causing this, but is there an alternative to it???

Thank you in advance

1 Like

Hi @analucia_espinoza,

I just tested the Jr:choice-name() for your case but could not reproduce the issue. FYI, i followed the following steps:

  • Uploaded the xlsform with Jr:choice-name(). You could try the one that i used shared here:
    2020 08 21 Jr.choice.withina.repeat.group.xlsx (10.6 KB)
  • Deployed the survey form.
  • Collected data through Enekto.
  • Sent to the server.
  • Went back to the server and then under the DATA>Table edited the submitted data by pressing the pen like Edit icon.
  • Did not see any error message.

Kindly please let me know if i did anything differently that what you have done. And by the way, i checked them both on the OCHA server as well as the HHI server.

Have a great day!

1 Like

Hello! @Kal_Lam How are you? thank you for your time!! I tried yours and it works, but investigating the @lognaturel answer in my other post I can see that the problem is related to the jr:choice-name() that access a select question with a filter…
I changed yours and reproduced the problem

2020 08 24 Jr.choice.withina.repeat.group.xlsx (15.9 KB)

I guess is what @lognaturel says, but I don’t know how can I know my enketo version :pleading_face: :pleading_face: :woozy_face: And less I know how to fix it :sob: Is this the last version of Enketo??
I really need to access the edit version!!

Thank you in advance :heavy_heart_exclamation:

1 Like

Hi @analucia_espinoza
I would just like to notify you that we are currently looking at this with our developers to really find the root cause of the failure to edit in this case. @Kal_Lam or I will keep you posted the sooner we get a clear indication. Apologies for any inconvenience.

Stephane

1 Like

Thank you very much :hugs: !

Please keep me posted!

2 Likes

Hello @stephanealoo,
Any news on this?
Do we have a github note on it?

Nope, I had to remove that part of the form :frowning: Is not looking good, but at least it works… Can you notify me when this is solved :confused: ?

Hello I’m having the same problem that you are, I wanted to know if you have overcome this problem, I have a set of 50 products that filter by categories, when I use the function jr:choice-me() to select the product label I have an error when trying to edit the collected data.

No. I had to remove it, because kobody solved it

Hi @analucia_espinoza, can you please see if the latest version of Enketo solves this issue:

1 Like