Cannot edit form - only affects one form for one user

Hi! Happy New Year! The site looks nice since the new year!
I have a problem with editing a form. I have 5 deployed forms. There are three users (non-owners) who submit data. They also have been given permission to go in and edit their submissions so that they can translate all text-entry questions.

However, for one user, on one form, we cannot make edits on her submissions. On the same form, for a different user, the edits are possible. I have tried going in as the form owner and also I cannot make edits.

I have also checked this same user on different forms - and edits are possible.

It’s just affecting a single user on a single form. She’s only made three submissions to the affected form so far. I’ve checked all three submissions and can make edits on none of them.

Any help would be much appreciated, or tips to try to troubleshoot?


Would you mind sharing with us the following information through a private message:

  • Username
  • Project name
  • Server

Maybe we could have a closer look at your case and see what should be affecting the edits.

1 Like

Have sent you a message, thanks @Kal_Lam!

1 Like

Sorry @janna, did not receive the private message. Could you kindly share it as outlined in the post discussed previously:

It should help us document our conversation systematically. Thank you for your kind understanding!

Okay, have now sent you three private messages…hopefully you received at least one :blush:

Received. Will get back to you shortly!

Hi @janna,

I could edit the submissions from both the users account (the admin as well as the enumerator’s). FYI, this is the screenshot captured while trying to edit the same with the admin account:

And this is the screenshot captured while trying to edit the same with the enumerator’s account:

Note: I used chrome and Edge to test this at my end. Would you mind advising your colleague to refresh the cache of the browser and try it again. Maybe your colleague should also update the browser if it’s outdated.

Kindly please let us know what happens. I assume it should not be a problem.

Hi @Kal_Lam,
It’s still not working, I’m sharing a screenvideo so you can see what happens. The error occurs when you change something and then hit “submit” at the bottom of the page.

So this is what happens for the user that’s having the issue:

And this is what happens for the same form, but a different user:

Can you please advise?

1 Like

Hopefully those gifs make sense, I realise they’re very low res. The first one (the user that’s having the problem) just spins and spins. We’ve tested leaving it to try and submit changes for up to three hours, just to see if it would ever submit. But it doesn’t ever submit the changes. The second one, with a different user that’s not having the problem, you click submit and it goes right away.

And with the same “problem” user, if you go to a different form where she’s submitted data, there is no problem. She can edit, make changes, and submit right away - no issues. It’s just with this form.


Yes, i tried in one of my dummy project and this should not be an issue of editing a submission. As a check, would you mind cloning the project that has an issue and then try to make an edits to a submissions for the cloned project. Maybe this should give us some clue if it’s an issue related to your survey project.

Kindly please let us know what happens.

1 Like

Hi @Kal_Lam,
Sorry it took me the rest of the day before I could do more testing. I cloned the project. However, the cloned project would not accept submissions at all - from either the “problem” user-account, nor other users. We’ve already been using this form with no challenges before this week. Is it possible there were updates to KoboToolbox that would have stopped a form from working? Sorry, just trying to brainstorm as I’ve not come across this before. Right now, at least one user can’t submit or edit data to the form, or a clone of the form - and other users cannot submit to clones of the form. It seems the form opens okay, etc. But when you press “submit”, it just spins and spins.

I’ve also tried uploading the XLSForm directly as a new project. This has the same problem. It uploads fine, deploys fine, I can open it and edit it in the editor, saves no problem. Can open the form to submit data, however, when I press the “submit” button, it just spins and spins. Any ideas? This affects all users, even myself as the form owner.


1 Like

Thank you for making a test. Will dive deep to your issue and get back to you shortly. BTW, is it OK if i make submissions to your cloned project for testing? Or, maybe i could also use the same xlsform with my account to check the issue.

1 Like

I really appreciate you looking into this, thank you. Yes, it’s absolutely fine to use and submit to that cloned project.

1 Like

Could you run the console (Ctrl+Shift+J) when trying this process for the user. Kindly capture the screen and share.

For comparison, do the same for the other user whose work and we see.

Could you also try removing the rights of the affected user, and according to the rights once again after about 5 minutes?


Hi @stephanealoo,
This is the video when running the console at the same time for the user who is affected:

Seems to be a lot of red errors…

Unfortunately, the other users are now impacted, so it is the same for all users now.

I made a new project with the same form. It is not possible to submit new data to the form, this is the video of that, with the console running:

Removing rights and giving rights again did not change anything.

Hope that’s helpful!

1 Like

Hi @janna
Thank you for the additional information. I am raising this with our developers and will get back to you when I get some feedback.


1 Like