Can't view my cascade list

help me.ADMIN14.xlsx (361.7 KB)

Have you gone through our support article Adding Cascading Select Questions. It should help you solve your issue.

In the meantime would also advise you to have a look at a simple workaround that should help you better understand the concept of a cascading select question. You could follow the same here:

And also follow a bit complicated cascading select here:

Having looked at your xlsform i could see that you have a lot of choices in your cascading select questions. This could slowdown your form loading and data collection process. You could thus use the select_one_from_file approach to overcome these issues following the instructions outlined in the post discussed previously:

1 Like

Hi @Kal_Lam Im having a similar issue. Trying to add a cascading question following the steps in Adding Cascading Select Questions — KoBoToolbox documentation as I have done before and this time after I enter “done” the examples are empty. Ive tried several times and same issues occurring. Any tips?

Hello @lucybattaglene,

Can you share a screenshot of your choices list?

1 Like

Sure. Attached here from XLS

I’ve also tried this one.

Thank you @lucybattaglene,

Can you also share the screenshot of the cascading question from your XLS form?

1 Like

Sure sorry- ends up looking like this:

Hi @lucybattaglene,

Let’s try this: Can you change the province names in your choices to not start with Uppercase Letters,
Torba → torba

Just like they are written in the name section :slight_smile:

1 Like

Thanks so much for your help- I’ve just tried what you suggested and still coming up the same- any other ideas and I can try them?

Can you share the new screenshot of your choices list?

1 Like

Sure the screenshots in my previous answer were the new outcomes in the form builder and here are the choices in XLS

Hi @lucybattaglene;

I tried to show the necessary changes you need to do in your screenshot:

What I’m trying to say is your Province column (D Column in your excel) should be same with your Name Column (B column in your excel)

1 Like

Oh sorry-Yep have just tried that and the same thing is happening. I’m not sure what the issue is as I have used the cascading feature before and it worked great.

Screen shows here of the XLS and form builder now…

Hi @lucybattaglene,

The names of the choices can’t contain spacebar instead you can use underscore _ (G column in your excel)

For example instead of writing north santo in your name list, can you try north_santo

Can you make the changes and let me know if that solves your issue?

1 Like

Thanks for the pick up- made the change (see screenshots) but same issue. I did just try to do a test version - pasting a table with only 2 provinces and 3 areac answers and weirdly it still ‘translated’ into the huge long list but with the same “empty” sign. Do I need to clear history or memory or something


If that’s the case, it seems the question doesn’t get the version you are trying to paste. Can you delete the question and try to add a new one?

Clearing your cache would also might help.

1 Like

thanks I just tried that and also using a different internet browser but same issue. If I do a mock version with limited choices it still translates into the longer list of ‘empty’ results. Any other ideas?

@lucybattaglene, can you able to change the form via uploading an xls form ?

1 Like

I haven’t ever tried this. What are the steps/template and I can give it a go?