Could not find photos files from within a repeat group

Dear @Kal_Lam,

I noted most of the uploaded photos in our forms doesn’t appear with message error " could not find file name"
Kidly advice me how we can fix this issue

Expected behavior

What you expected to happen

Actual behavior

What actually happened, you can add screenshots if applicable

Additional details

Your environment, why you think this might be happening, or stuff you tried that didn’t work

- What should topics in this category generally contain?

- Do we need this category? Can we merge with another category, or subcategory?

@iraq_habitat, could you provide me the following through a private message? Maybe I could have a closer look at your case.

  • Username
  • Project name
  • _id
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

@Kal_Lam , I sent you the information you asked in private message

1 Like

@iraq_habitat, I had no issues viewing the images … FYR …

But when scrolling down, I saw this …

Were they taken from the camera (device) when collecting data, or were they uploaded from the device? Is this what you are trying to refer to as the issue?

Yes, the files that not appear with error “could not find filename.jpg” those before were OK, but now are not show up

@iraq_habitat, were they uploaded as media files or were they captured by the device and then submitted to the server?

@Kal_Lam most of them captured by the device then submmited to the server

1 Like

@iraq_habitat, could you also let us know if you used the Collect Android App or Enketo for this?

@Kal_Lam if you mean Kobo app yes they use Kobo app for data collection

1 Like

@iraq_habitat, I made a quick check on the same server (EU server) where you had the issue but could not replicate your issue. I tried uploading an image from my PC and also tried another one by capturing an image from my device and then uploaded the submission to the server to see if I should have any issues but unfortunately, I did not have any issues. Everything was visible on the server. Could you quickly try these with a dummy project to see if you should be able to replicate this issue? Let me know the exact steps if you are able to.

@iraq_habitat, I understand why you are not seeing the images. It seems like you are within the repeat_group


Maybe we need to create a new feature request for this issue.

@Kal_Lam for many years it was OK, recently this issue happened even those submission today our data collectores submmited have the same issue. is that some issue from the server or the images missing? when it can be fixed?

@iraq_habitat, are you sure you could view the images from within the repeat group before, too? Kindly confirm, and I can check out if it’s a bug that is affecting the same.

@Kal_Lam, Yes I’m sure for long time we are using this kind layout form for many projects and we didn’t have issue with it

1 Like

Thank you for confirming this, @iraq_habitat! We will update you once we find out if there is any bug on this.

Thank you, I wait for update

1 Like

I also faced this problem. I will be glad if everything returns to the way it was before.

1 Like

@iraq_habitat, @Maksym1793, kindly be informed that we confirm its a little bug on our end, and our team is working on it. I will let you know once it’s resolved.

thank you.


1 Like

@Kal_Lam, any update about this issue? tha’ts make our job diffecult