Do you have any insight on what might cause the survey to delay in being able to be viewed?

Do you have any insight on what might cause the survey to delay in being able to be viewed?

I have shifted this to a new topic as it should be different from what we were discussing previously. This should help us index the issues systematically so that the community would benefit if and when required.

Sorry, I did not understand you correctly. Could you kindly elaborate on your issue so that we could provide you with a suitable response that should answer your query?

@Kal_Lam , absolutely!
I created a survey using an XLS form. I was able to upload it as a draft and deploy it on Kobo without any error statements. I then tried to view the instrument by opening a Collect Data (“Online-only (Once per respondent”) link. When I tried to open the link, it would take a long time to load before giving me an error statement “Unexpected token < in JSON at position 0”. This is the error statement I would see in Chrome. I logged out of Kobo on Chrome, logged into Kobo on Safari and tried to open the Collect Data link. The same thing happened except this time I received a “String does match match the expected pattern” error.

I tried re-uploading the same XLS form several times to see if this would address the issue. I tried using different types of collect data links, as well. However, in Chrome I would always see the above “Unexpected token” error and similarly in Safari I would always see the “Sting does not” error. I then left the survey overnight (I did not change the XLS form after seeing the last error statement I left the error producing form overnight) and then when I tried to open the collect data link this morning it worked without a problem. I wanted to know if there is any documentation on what could cause a form to delay in being able to create a working collect data link (i.e. which does not produce any error statements) and specifically to start working after some time has passed and no change has been made to the form?

This is something weird but interesting too. Maybe we will keep an eye on this issue to see if anyone else from the community experiences the same at their end too.

It is a good thing this is working. If you experiences this error in the future , please share either the link to a failing draft page or screenshot of the errors in the JavaScript console. It seems like Enketo or Preview was not able to make successful requests to the servers.


1 Like

Maybe, also to keep in mind what may have happened on your device between the two exercises . For ex.

  • Cleaning of browser cache,?
  • Cleaning of cookies?
  • Better WLAN / Internet connection?
1 Like