Download stucks on "Processing…"


I’m trying to download an xls data from my form, but this time it keeps stuck on “Processing…”, I tried giving it time to process, but it didn’t help.

Searching the community I found that several issues of such had taken place, but it takes too long and never finishes.
BTW I’m on the “humanitarian response” server.

similar problem to mine:

I was asking the same! Hope this can be solved ASAP… :crazy_face:

thanks for any advice, my boss is asking me to update the dashboard and I am stuck on “processing”

Thank you for bringing this to the community, @collect, @chiaramar! We will investigate and come up with a solution soon.

Thanks @Kal_Lam !

1 Like

Thanks. @Kal_Lam

1 Like

@collect, @chiaramar, please be informed that the issue has been resolved! Thank you for your kind understanding and patience!

Thanks! It worked! I really appreciate all your support!

1 Like

I have the same problem, please solve it, even for our company account we have the same issue.

Th issue continue on my side.
I stil can’t download XLS data.
02 September 2023, 01:00 AM

@halzorqah, are you still having issues?

Welcome to the community, @brahitoure! Are you still having issues?

The problem is solved, thanks a lot.


The server -domain name- has changed to “kobotoolbox”.

1 Like

Thanks a lot.
The problem is solved now.


1 Like

@collect, @brahitoure, thank you for confirming! :clap: :heart: :partying_face:

1 Like