Downloading XLS Forms

I was not able to download the XLS form for the Kobo form to include some images. When trying to download it causes the issue accessing the server and needs to re log in. Need a solution.

Welcome to the community, @Diluksion_1979! Are you still having this issue? If yes, could you let us know the server you are using and also share with us a screenshot of the same?

Yes, I was not able to download the XLS for the Forms?
I have tried several times and have not been able to download them.
Let me know if this has something to do with the account or with the server.

@Diluksion_1979, would you be able to share with me the following (through a private message) so that we could have a closer look at it?

  • Username
  • Project name
  • Server

Username - xxxxxxx
Project name - Asia Innovation Network 2021
Server -

@Diluksion_1979, I gave a quick try and could download the xlsform as well as your XLS data from your project. Would you mind trying it with a different device?

I’m having the same issue of finding it difficult to download the XML and XLS survey to make some changes.

I was not able to download the XLS and XML versions of the forms to include images. I had this issue before and having this again. This is very discouraging to continue using Kobo.

Is it the same issue you had faced previously? If you are still having issues, please feel free to share with me the following through a private message so that I could have a closer look at it?

  • Username
  • Project name
  • Server

Hello Kal,
Seems once I refresh the page or close and open the page and then tried it works and downloads the xls.
If you still wants to check, it was the same details as I’ve provided before.

Diluksion Francis
MEAL Coordinator | Oxfam in Sri Lanka | Mobile - 094775592288 | Skype - Diluksion

Great to know that your issue was solved. Thank you for confirming!

I’m again having issues downloading the XLS to translate and including some changes…Why is this often occurring? If this can’t be resolved, I will use something else this has become nusense.

Issue with the same project I found it difficult previously.

@Diluksion_1979, could you also share with us a screenshot of the issue so that the community should be able to understand it pictorially?

Hi Kim,

There are no screenshots as nothing happens when I click “Download XLS” of a form I built.

Sometimes, it happens through random licks (probably when I click 5-10 times, etc.).


So you mean you are not able to download your form as XLSForm? Is this issue still on or does it only happen at times?

Yes, exactly. It happens very often. It never downloaded at first. I have to either refresh the browser, actual cash, etc., then try back.


Are you currently facing the issue?

Yes, I’m having difficulties and it doesn’t download XLS.

Would you mind changing the browser to see if that should help?