Error in deleting a record

While deleting a record from data I am getting an error message “Failed to delete submissions”. Attached is an image for your reference. How can I delete the said record?


@mandarsathe, are you still having this issue?


I have the exact same issue: deleting a submission gives the error message as shown in the picture of Mandar above.

Deleting a submission through the API v1 doesn’t work either, and there it doesn’t give an error message back, unfortunately.

Any suggestions on what to do?

Many thanks!

Hi @bert12, are you the owner of the project or has it been shared with you?

1 Like

Hi @Josh,
Thank you for checking in, yes, I am the owner of the project.

Hi @bert12, is this a persistent issue or was it a once off occurrence?

Hi @Josh,

Yesterday and today, also again just now, I tried a couple of times and the report won’t delete, so it feels like the issue is persistant. These attempts were manually through the Kobo website interface.

A curl request to the API v1 to delete the report through a script gave a server response back as if the delete was successful, but in reality the report is still present. Since the API v1 doesn’t give an error back, people who have automated their report handling are not notified that something went wrong. This can cause problems in data sets.

Would be great if it would be fixed, many thanks in advance!

Hi @bert12, I apologize for missing this response. It looks like the same issue from here. Can you and @mandarsathe please send me a private message with the following:

  • server (HHI/OCHA)
  • username
  • project
1 Like

Bjr, j’ai besoin aussi de l’aide à ce sujet, j’ai le même problème que sur 2 enregistrements, les autres je parviens à supprimer mais pas 2. Que faut-il faire?

Welcome to the community, @jtshimena! Could you also share with me the following through a private message:

  • Username
  • Project name
  • The _id for those records which you were unable to delete
  • Server

Bjr Kal, Merci pour la réponse, je veux savoir comment envoyer le message en privé ou bien je dois juste réponse à votre message, comme je suis entrain de le faire maintenant. Merci de m’indiquer le chemin à suivre.

@jtshimena, you could send me a private message as outlined in the post discussed previously:

Hello, I’m Andy and experiencing the same issue, but from the API (started on Friday I believe) where I can’t delete entries. We’re connecting to and the login is xxxxxxx. The specific survey that failed was 476370, though there may be others. The first entry to fail was 221028360. Thank you for your help in getting this back up as it is a mission critical part of our system!

Merci beaucoup, mais j’ai un message d’erreur à l’envoi du message personnel, le voici:
“Désolé, vous ne pouvez pas envoyer de message personnel à cet utilisateur.”

You should now be able to send me a private message. If you are still having issues, please refresh your page.

Welcome to the community, @rockychat3! Did you also try deleting your records through the UI?

I am a bit gunshy about and manual deletes since our script only deletes after verifying a successful copy. It has worked perfectly for over a year until a few days ago (similar to the other posts on the forum). Thank you,

Hi @rockychat3 and @jtshimena, your projects should be functioning normally now :+1: thank you for your patience.


Just tested and it all seems great, thank you!


Merci beaucoup, ça fonctionne maintenant. Bonne journée